[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 457
  • Last Modified:

2003 32bit to 2008 x64 migration

I'm upgrading my Domain from 03 to 08.  Two Servers.  The 03 server is 32bit, the 08 server is 64bit.  I think I may have screwed myself.  I ran the adpreps (forestprep and domainprep) on the 32 bit server from the 64bit media.  Now when I try to dcpromo from the 08 machine it errors out saying I need to run forestprep.  A little research tells me i needed to run the adpreps from 32 bit media, is it possible to backout the adpreps.  If not, what are my options to do the migration, if any?
0
gthmpd
Asked:
gthmpd
2 Solutions
 
Nagendra Pratap SinghCommented:
What is the exact error message?
0
 
gthmpdAuthor Commented:
On the 08 server, at the "select a domain" window of DCPromo, after pressing next the pop up reads:

 "To install a domain controller into this Active Directory forest, you must first prepare the forest "Adprep /forestprep". The Adprep Utility is available on the Windows Server 2008 R2 installation media in the \support \adprep folder."

I tried re-running Adprep from the 32 bit media and got this message:

"Forest-wide information has already been updated.
[Status/Consequence]
Adprep did not attempt to rerun this operation."

Thanks,
0
 
David Johnson, CD, MVPOwnerCommented:
I think I may have screwed myself.  I ran the adpreps (forestprep and domainprep) on the 32 bit server from the 64bit media

Restore from backup and DO NOT use any S2K8 tools on the S2k3 machine EVER..
I hope some other experts have better solutions for your sake
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
arnoldCommented:
On the win2k8 x64 media there adprep32 that you would use.

Did the adprep actually run or did it error out?
Make sure to use a command window this way you can see errors if any.

The error you get suggests that the adprep you tried running did not actually run.
Location of adprep32
http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/d4f83329-10e0-43d7-b8cd-476dba8e0709/

Driveletterofdvdrom:\support\adprep or \sources\adprep
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
You didn't do anything bad to AD - don't worry about it.  ADPREP will not run if it's run on the wrong platform (64 bit on 32 bit) and it can only update if the updates haven't been applied... the updates are the same regardless of which ADPREP is run so you can't mess it up that way.

2008 R2 doesn't have a 32 bit version, so if you ran a 32 bit version you ran the 2008 (non-R2 version which is older and different) then you didn't update 2003 AD to a new enough schema so you're getting a message that the schema must be updated.

If you did run the correct version, then you may not have run it on the correct DC.  Please follow this guide CAREFULLY and you should be fine:
http://www.petri.co.il/prepare-for-server-2008-r2-domain-controller.htm

(I'm assuming you have 2008 R2 because you mentioned it in one of your comments... but your question states 2008.  So please CLARIFY as this is a VERY important detail).
0
 
gthmpdAuthor Commented:
Thanks Arnold.  As Mykul experienced in that thread you provided, I had a bit of trouble finding a copy of Win08 with Adprep32.   Once found and ran, it worked as intended.

@ve3ofa   That was my next step.  Was hoping not to have to do that as I've had bad luck restoring a DC in the past  :)
0
 
gthmpdAuthor Commented:
Thanks LeeW  for the Petri link. The more resources the better.  CAREFULLY... got it   ;)
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now