Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 480
  • Last Modified:

Cisco CLI Views

Hi

I have a very annoying problem. I am configuring Cisco views and everything works great until I access the routers remotely. For some reason the helpdesk user I created and locked into a view has access to all commands. This is not the desired effect. Here is the config;


!
upgrade fpd auto
version 12.4
parser view helpdesk
 secret 5 $1$Zmg4$WcCToFXjLLHEalvkfn84j.
 commands exec include all show
 commands exec include all debug
!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip domain name cisco.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 password 0 cisco
username helpdesk view helpdesk password 0 cisco
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.8.222 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.8.254
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
!
end

What am I missing here?
0
Leedham2answers
Asked:
Leedham2answers
1 Solution
 
ArneLoviusCommented:
remove "all"

parser view helpdesk
 secret 5 $1$Zmg4$WcCToFXjLLHEalvkfn84j.
 commands exec include show
 commands exec include debug

Open in new window

0
 
Matt VCommented:
When you login as helpdesk remotely, what prompt do you see and what is the result of show priv?
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now