Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1042
  • Last Modified:

Hot swap SATA.

The computer case that I bought has a disk docking slot where I can plug and remove disk. I thought this is very useful to do my daily backup.

My pc has 4 disks in raid 1 in pci express controller.
For the docking slot, I connected to my intel motherboard DG33TL. When I tested hot swap of a disk in the docking slot, it gave two errors;
======================================================
Event 12:
The device 'WDC XXXXXXXXXXXX' (IDE\DiskWDC_WD10EADS-00L5B1_____________________01.01A01\5&1a04b4bb&0&0.1.0) disappeared from the system without first being prepared for removal.

Event 57:
The system failed to flush data to the transaction log. Corruption may occur.
======================================================
After research, I enabled AHCI on the motherboard disk controller, and disabled writing cache on the disk. After reboot, I tried again, one of two errors is gone, Event 12. But I still don't see the 'Safely Remove' on taskbar. I reinstalled Intel Rapid Storage manager, but still no change.

Two issues.
1. I don't see 'Safely remove' icon on taskbar or device manager under USB or disk controller even though I enabled ACHI and installed all drive controller of the motherboard.

2. Still getting Event 57 when I remove the disk.
0
crcsupport
Asked:
crcsupport
  • 3
2 Solutions
 
DavidPresidentCommented:
You can't just pop out a disk that is part of a RAID1 set with any controller and use it as a backup.   They aren't designed for it.  Not only that, you do put your data at risk by degrading a perfectly good redundant array.

Remember blocks fail too, so you could have an unreadable block on the disk that you didn't remove, and when you unplug the disk, you GUARANTEE data loss.

The right way to do this is get a non-RAID port like eSATA or USB3 and use that for a proper backup device.
0
 
crcsupportAuthor Commented:
dlethe,
as I said, the disk is not belonging to the raid controller.
0
 
Handy HolderSaggar makers bottom knockerCommented:
0
 
crcsupportAuthor Commented:
andyalder, I have windows 2003 64bit installed, it doesn't support it. But thanks.
0
 
crcsupportAuthor Commented:
I just plugged esata port on motherboard to docking station, works wonderful.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now