?
Solved

Login Script not working on TS

Posted on 2012-09-21
8
Medium Priority
?
562 Views
Last Modified: 2012-09-25
I have a vbs login script running via Group Policy. All is working correctly but when the user logs into the terminal server, the drives are not mapping. If I manually run the script it maps. Not sure why the script is not running on the terminal server.

Any ideas?
0
Comment
Question by:j8547
  • 4
  • 3
8 Comments
 
LVL 14

Expert Comment

by:Justin Yeung
ID: 38422830
check is the server is really applied for the GPO.

gpresult (w2k3)
gpresult /r (2k8)

do you have any other gpo applied to the TS which blocked inherited?

under gpresult will tell you exactly what policy has been applied to TS and it is a user configuration under GPO, do you have loop back enabled on the TS gpo?
0
 

Author Comment

by:j8547
ID: 38429718
I can see the GPO is not running. It should map the drives. This is user specific. Does this not work with TS
0
 
LVL 24

Expert Comment

by:Dirk Kotte
ID: 38429751
have you configured a loopback-ploicy with "replace" option?
this gpo replace the user gpo(s) with gpo(s) bound to the OU from the TS.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:j8547
ID: 38429782
yea it was already set to 'replace'
0
 

Author Comment

by:j8547
ID: 38429783
should it be merge?
0
 
LVL 24

Accepted Solution

by:
Dirk Kotte earned 2000 total points
ID: 38429795
it depends :-)
if you create all nessesary rules separately for the TS - OU you can replace the user-gpo.
i prefer this, because i better can control the settings ate the ts.
if you have different settings at different user-groups made at the user-gpo this is not simple to do with replace - here i would use "merge"
0
 

Author Comment

by:j8547
ID: 38430192
Changed it to merge and still not running.
0
 
LVL 24

Expert Comment

by:Dirk Kotte
ID: 38431180
run gpupdate /f
wait a moment ...
check with gpresult.exe or rsop.msc
(logonscripts should work at TS also)
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question