Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1159
  • Last Modified:

AutoPlay Won't

Win7[64]

I have a Canon G12 camera that has stopped "auto-playing" when I connect it [USB2] to the computer. This started about a month ago after using the camera for 8 months.
I previously had a Canon G11 that connected just fine.

The Canon software is designed to open "CameraWindow" for managing the on-camera images when the camera is connected & power up.

The computer sees the camera & I can manually connect to the camera with the Canon software, but I want to restore the auto-play.
I have removed & reinstalled the camera driver [Windows] and updated the Canon software but no joy.
It doesn't matter which USB port I use.

Interestingly enough, Windows AutoPlay still shows my old G11 with a ton of options for what to do when it is connected (including opening with CameraWindow), but the G12 shows only two options:
"Open Device Stage" & "Take No Action"
I cannot change the options for the G12, nor can I find a way to remove the G11 from the list.
Setting AutoPlay to Defaults has no effect.

What can I do?
0
Prester John
Asked:
Prester John
1 Solution
 
Sushil SonawaneCommented:
Please refer below link to change the autoplay setting

http://windows.microsoft.com/en-US/windows7/Change-AutoPlay-settings

OR

Follow these steps:


Click the Start button , click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

At the command prompt, type net start shellhwdetection, and then press Enter.

Restart your computer.

(http://windows.microsoft.com/en-US/windows7/Troubleshoot-AutoPlay-problems)
0
 
captainCommented:
Looks like a cut & paste from the MS site^

If that does  not work, check the Local Group Policy (RUN > Gpedit.msc)

Go to Computer Configuration > Administrative Templates > Windows Components

There is an Autoplay Config entry there. Check Settings to see if it is disabled.

hth
capt.
0
 
Prester JohnAuthor Commented:
Thanks sushil84 & capt.

sushil84's direction to use the net start command worked exactly right.

Once I did that, a connection manager-type of window came up that allowed me to choose the default application for the G12 & now CameraWindow opens just as it should.

[ Funny that I missed that command when looking through the MSKB :-/  ]
0
 
dhsindy SparrowRetired considering supplemental income.Commented:
I noticed in the instructions it said that the camera Power Saver won't work when in Autoplay.  That made me wonder if it disables Autoplay when you turn it on.
0
 
Prester JohnAuthor Commented:
I don't ever have the camera connected for more than a few minutes so I haven't bothered enabling the Power Saver.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now