• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 689
  • Last Modified:

php for linux

hello there,
I have downloaded the latest version of php which is v5.4.7
I am able to compile on my centos v5.7 web server running apache and all is good until I try to compile the php extensions to use as modules..
I have been trying to find the compiled extensions for 32/64bit but I cant find them and I also have issues compiling them.. half of them compile ok and the others give errors..

this is what I do
cd /php-5.4.7/ext/mysqli
phpize
CFLAGS=-m64 CPPFLAGS=-m64 CCASFLAGS=-m64 ./configure
make

make: *** [mysqli.lo] Error 1
0
XK8ER
Asked:
XK8ER
  • 2
  • 2
1 Solution
 
themrrobertCommented:
Found some info that might help:
 
Installation
 
 To install the mysqli extension for PHP, use the
--with-mysqli=mysql_config_path/mysql_config configuration
option where mysql_config_path represents the location of
the mysql_config program that comes with MySQL versions
greater than 4.1.  
 
If you would like to install the mysql extension along
with the mysqli extension you have to use the same client
library to avoid any conflicts.  

https://bugs.php.net/bug.php?id=29979
0
 
XK8ERAuthor Commented:
okay.. how about for these?

imap            configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing.
ldap            configure: error: Cannot find ldap libraries in /usr/lib.
mbstring      make: *** [mbstring.lo] Error 1
mcrypt            configure: error: mcrypt.h not found. Please reinstall libmcrypt.
mysql            make: *** [php_mysql.lo] Error 1
mysqli            make: *** [mysqli.lo] Error 1
zip            make: *** [php_zip.lo] Error 1
xsl            configure: error: xslt-config not found. Please reinstall the libxslt
pdo            make: *** [pdo_dbh.lo] Error 1
pdo_mysql      make: *** [pdo_mysql.lo] Error 1
pdo_sqlite      configure: error: Please reinstall the sqlite3
0
 
themrrobertCommented:
It looks like all of these are because some configuration is flag.

Try searching on Google for the error message and you should get the answer you need.

Example: google search for: make: *** [pdo_dbh.lo] Error 1 should lead you to the configuration setting you need to build it.

If you get stuck on a couple after you tried a few different solutions, let us know :)
0
 
XK8ERAuthor Commented:
I am still looking around to at least get some more extensions compiled i installed development tools that someone said it works from a forum but that did not help either..
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now