[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Unable to install KB2705118 (WHS 2011 Rollup 3)

Posted on 2012-09-22
3
Medium Priority
?
972 Views
Last Modified: 2013-12-02
Hi,

I am having major problems with my WHS 2011 which I hope someone can assist with. No matter what I do I am unable to reinstall Rollup 3.

The problem was discovered when I tried to add my MediaCenter PC and it kept failing to add to the server and the event log kept saying that the kb2705129 cab was corrupt. I uninstalled KB2705118 on the WHS, rebooted then tried to reinstall it to no avail. It failed to install so I then followed the MS guide at MS KB2509997 again to no avail. I've also tried renaming the system32\catroot2, and SoftwareDistribution\Download and Datastore folders to no avail.

When I run SFC /SCANNOW from an elevated CMD prompt on the server the log does show corruption and I have attached the CBS Log here should anyone be able to help.

Please can anyone offer a solution to this so I can cure the corrupt files and get the Rollup reinstalled as I really don't want to reinstall the server from scratch.

Thanks,

John
0
Comment
Question by:DeepSeaPLC
  • 2
3 Comments
 
LVL 6

Expert Comment

by:arroryn
ID: 38425185
Have you tried a cab file repair tool at all? I haven't tried any of these as I've never had the specific issue, but it is a common issue on boards and might be worth an exploration:

http://www.google.co.uk/search?hl=en&site=&source=hp&q=repair+corrupt+cab+file&oq=repair+corrupt+cab+file&gs_l=hp.3..0.840.4153.0.4272.25.19.0.0.0.0.275.2014.8j4j4.16.0.les%3B..0.0...1c.1.9M9x4C8spKY
0
 

Accepted Solution

by:
DeepSeaPLC earned 0 total points
ID: 38428999
Hi,
I found that it was a corrupt package manifest in the windows\servicing folder that was causing me the problem however the quickest way to repair it was to format the server and reinstall.

John
0
 

Author Closing Comment

by:DeepSeaPLC
ID: 38446877
The suggestion provided by the other user was now suitable for this problem. Reinstalling the system was the quickest way to get system back online.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every system administrator encounters once in while in a problem where the solution seems to be a needle in haystack.  My needle was an anti-virus version causing problems with my Exchange server. I have an HP DL350 with Windows Server 2008 Stand…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Screencast - Getting to Know the Pipeline

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question