?
Solved

Copy/paste with Microsoft Remote Desktop

Posted on 2012-09-22
35
Medium Priority
?
2,462 Views
Last Modified: 2012-10-12
I'm using Microsoft Remote Desktop and have Clipboard checked under the Local Resources.  However, I cannot copy/paste from the host OS into the remote session or vice versa.  Any suggestions on what else I need to do?
0
Comment
Question by:brettr
  • 16
  • 12
  • 4
  • +3
35 Comments
 
LVL 18

Expert Comment

by:awawada
ID: 38425088
Open Task Manager and kill the rdpclip.exe process
Run rdpclip.exe to restart it

Will it work?
0
 

Author Comment

by:brettr
ID: 38425175
I don't see the process you're referring to.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38425195
You should see it like here

rdpclip
If you can't see just start rdpclip.exe
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 

Author Comment

by:brettr
ID: 38425208
Sorry - it isn't there.
Windows-XP---Parallels-Desktop-1.jpg
0
 
LVL 17

Expert Comment

by:Sikhumbuzo Ntsada
ID: 38425288
If it was working before, maybe the clip board is full - reboot your client machine and try again.
0
 

Author Comment

by:brettr
ID: 38425315
It has never worked.
0
 
LVL 13

Expert Comment

by:lauchangkwang
ID: 38425811
check the computer policy by "start" > "gpedit.msc" , then search for the location as below,

group policy
0
 
LVL 18

Expert Comment

by:awawada
ID: 38425874
Sorry - it isn't there.  

And you can't scroll down?
0
 
LVL 72

Expert Comment

by:Qlemo
ID: 38426161
You should check for rdpclip.exe in the remote session, not locally.
0
 

Author Comment

by:brettr
ID: 38426571
@awawada: You can see processes are arranged alpha.  Where are you wanting me to scroll too?

@Qlemo: Not there either.

@lauchangkwang: This was set as not configured, as shown in your screenshot.  That is the default and should allow for copying/pasting.  I changed it to disabled, which is the same as the default but I still cannot copy/paste.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38426611
@brettr
Oh yes I didn't see that. What happens if you open command prompt (locally), type rdpclip.exe and hit enter? Can you copy/paste now?
0
 

Author Comment

by:brettr
ID: 38426653
Tried that.  I can see the process is running on my local now.  I restarted Remote Desktop.  I started rdpclip.exe on the remote but it doesn't show up in processes.  The remote is running Windows Server 2008 R2 Standard.  Still no change.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38426669
I can see the process is running on my local now... on the remote but it doesn't show up in processes
You don't need start rdpclip.exe on the Server. Now rdpclip.exe is running locally?
0
 

Author Comment

by:brettr
ID: 38426700
Yes - it is running locally.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38426781
Can you copy and past to Notepad on the Server?
0
 

Author Comment

by:brettr
ID: 38426855
Nope.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38426943
Is the client up to date? If no please update the system and run sfc /scannow under the command prompt (locally as Administrator).
0
 

Author Comment

by:brettr
ID: 38427010
What do you mean by is the client up to date?

I ran the scan.  Not sure what happened since I wasn't there when it completed.  The scan window isn't there anymore.
0
 
LVL 17

Expert Comment

by:Spike99
ID: 38432985
In my experience, you need to have 3 elements to get it to work:
1.  RDPClip.exe has to be running on the server under the user's session
2.  the clipboard option has to be enabled in the RDP connection
3.  also, local drives have to be enabled in the RDP connection & at least the C: drive checked

Not sure why number three is necessary, but usually when users are having issues with copy/paste, I have them enable local drives & then log back on & that usually resolves it.

See the screenshot
Screenshot of RDP local devices
0
 

Author Comment

by:brettr
ID: 38433206
@Spike99: Tried your suggestion.  Still nothing.  I noticed the remote server does not have rdpclip.exe.  I did download it but it still doesn't start.  I read the following article, although it is for 2003 and not 2008:

http://thebackroomtech.wordpress.com/2009/05/14/fix-rdpclip-exe-wont-run-on-windows-server-2003/

fDisableClip was already set to zero.  So no help there either.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38433781
What do you mean by is the client up to date?

Do you run Windows Updates?

I ran the scan.  Not sure what happened since I wasn't there when it completed.  The scan window isn't there anymore.

This is not normal
0
 

Author Comment

by:brettr
ID: 38433845
Yes - Windows is up to date.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38433915
Please run sfc /scannow >c:\log.txt again under the command prompt (locally as Administrator).
0
 

Author Comment

by:brettr
ID: 38433955
My XP CD is now buried in the closet again.  I rarely use it.  The scan requires the XP CD.

However, I do not think the local is a issue.  It is a problem on the remote because rdpclip.exe isn't running.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38433972
This is not a CD Problem! Did you run the scan?
0
 

Author Comment

by:brettr
ID: 38434009
The scan requires the CD:

Files that are required for Windows run properly must be copied to the DLL Cache.
Insert your Windows XP Professional CD-ROM now.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38434022
Can you organize a new CD?
0
 

Author Comment

by:brettr
ID: 38434037
What do you mean?  The one I have works.  I'm just not inclined to dig it out since I know the fix you're wanting applied isn't going to solve the problem.  Until rdpclip.exe can run on the server, I can't copy/paste between these two machines.
0
 
LVL 18

Expert Comment

by:awawada
ID: 38434080
It's worth a try. Then I have no more idea.
0
 
LVL 17

Expert Comment

by:Spike99
ID: 38434900
Did you check Terminal Services Configuration?  I think if the option to disable clipboard mapping is checked, it will prevent RDPClip from running.

check out these screenshots. The one on the left is from 2008, the one on the right is from 2003.  You can find TSConfig under in the Administrative Tools > Terminal Services folder in 2008 or in Administrative Tools in 2003.

Terminal Services Configuration - RDP-TCP Client Settings
0
 

Author Comment

by:brettr
ID: 38434925
I don't see it under Admin Tools.  Perhaps I don't have permissions to access it.  Is there another way to check?
0
 
LVL 17

Expert Comment

by:Spike99
ID: 38434934
You can start the TS Config tool by typing in the command in the RUN line:

tsconfig.msc   in Server 2008
tscc.msc    in Sever 2003
0
 

Author Comment

by:brettr
ID: 38434951
Thanks.  The clipboard option is not checked in RDP-Tcp.
0
 
LVL 17

Accepted Solution

by:
Spike99 earned 2000 total points
ID: 38438303
I have googled this issue extensively & haven't found any helpful hints.  

A few years ago, one of our customers had an issue with copy/paste not working.  Basically, every time they launched Great Plains 9.0 & ran some report, it would break RDPClip.exe. The only solution was to upgrade to GP 10 or later, which they were not prepared to do at that point.  After looking at the link you posted, I think that clipboard "chain" was being broken by GP.

But, in that case, RDPClip.exe was running for each user in their TS session, it just didn't work anymore after they got into GP. so, my solution then was to create a BAT file for them that would kill RDPCLIP on their session, wait a few seconds & then re-launch it.

But, in your case RDPClip isn't running at all, isn't that right? Have you tried using procmon to see what is killing the process? mabye that would help shed some light

Or, have you checked properties of the RDPCLIP.EXE file? do users have rights to run it? I think it's in the system32 folder.
0
 

Author Closing Comment

by:brettr
ID: 38491305
I think this has turned into impractical in regards to time.  I've gone with a web based solution.  Thanks for all of the suggestions.  Nothing in the end seemed to get RDPCLIP.EXE working.  I would likely have to get a local admins involved and they will probably not do anything.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
Let’s list some of the technologies that enable smooth teleworking. 
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question