Link to home
Create AccountLog in
Avatar of Eric Sherman
Eric ShermanFlag for United States of America

asked on

Can't Delete Emails in Outlook Drafts Folder???

I have a Access app that creates some emails and dumps them into the Drafts folder of Outlook.  I can send them but I can't delete them if need be until each email is opened first in the Drafts folder.  Say if I process a run with 50 emails in error and they need to be deleted.  Having to open each one first is very time consuming.  This happens with Outlook 2003 and Outlook 2007.

Any ideas on why the emails in the Draft folder simply cannot be deleted  will be appreciated.

Thanks,

ET
Avatar of arroryn
arroryn
Flag of United Kingdom of Great Britain and Northern Ireland image

What error message do you get when you try to delete them en masse? Have you tried this in OWA and can you delete them all in one go there?
Avatar of Eric Sherman

ASKER

Thanks for the reply arroryn....

Error Message: The item could not be deleted. It was either moved or already delivered or access was denied.

What is OWA???

This is Outlook 2003 and not using Exchange Server.

ET
Try deleting your forms cache and trying again:

1.On the Windows taskbar, click Start, point to Programs, and then click Windows Explorer.
2.In Windows Explorer move to the \Windows\Forms folder on your hard drive.
3.Under the Forms folder, one at a time, click to select each sub-folder, except the Configs folder and press the DELETE key. When prompted Are you sure you want to remove the folder"<folder name>" and all its contents to the Recycle Bin? click Yes. Repeat this for each folder, except the Configs folder.
 4.Under the Forms folder, click to select the Frmcache.dat file and press the DELETE key to delete this file. Repeat this process for any other files in the Forms folder.
No Forms folder exist under Windows.


ET
Turn off Cached Exchange Mode and try agian
What OS are you using please ET?

-Arro.
arroryn ....

Windows 7 Professional with Office 2003

apache09 ....

I will try and respond.  Where is the Cached Exchange Mode option located???

ET
Under tools>account settings

Open the users Outlook Profile
Under Exchange Server Name you will see a tick boc for
use cached exchangemode

untick, and restart outlook
apache09 ... This machine is not using Exchange Server.

ET
ASKER CERTIFIED SOLUTION
Avatar of Eric Sherman
Eric Sherman
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
check clear entire forms cache here:

http://support.microsoft.com/kb/291183
Ahh okay


In that case im wondering if the Access application is retaining a lock on those drafts or the pst until outlook is used to access/open the draft item, then allowing for the mail item to be deleted

Is access open or closed when trying to delete the drafts?
If close, check your task Manager, look at the processes and make sure the MSACCESS Process is not still running. If it is, end the process

If you close and reopen outlook, then try and delete does this make a difference?
Tried it arroryn ... still will not allow the messages in the Draft folder to be deleted.

For now, I can live with the work around that I figured out although it just doesn't make sense that the messages can't be deleted by selecting them and hitting the delete key.

ET
apache09 ... Tried that at first to no avail.  The Access app is closed and no locks are on the files.

I've seen this on other machines as well.  The only thing I did notice is when the Access app dumps the emails into Outlook's Draft folder, they have a Sent date filled in as shown in the picture below.  By opening each message or setting a flag on each one removes the Sent date and the message can be deleted.

ET

User generated image
Hrm

have a look and see if the following patch is installed on the machine

Update for Microsoft Office Outlook 2007 (KB972363)

If so, see if you can remove the update as its known to add sent dates to draft items
Thanks for the suggestion but it is a remote pc at a client's site and I prefer to not make any changes.

I will just use the work around that I came up with.  

Again, your comments are appreciated.

ET
This work around seems to resolve the problem.  Thanks all for your input.

ET