Avatar of Matthew Ayers
Matthew Ayers
 asked on

Userenv Error 1054

I have been seeing these errors show up in the server logs recently. I have run dcdiag and all the tests pass, on running netdiag the DNS test fails saying can't find an authoritative DNS server for our server. It says it is not correctly registered on server 0.0.0.0. Running IPconfig /all shows the DNS server with the correct IP address. Both the DNS server and the DC are the same server. Running netdiag /fix does not work it can't register with the DNS server. I have attached a DNSlint report which may help. Thanks.
Windows Server 2003

Avatar of undefined
Last Comment
Matthew Ayers

8/22/2022 - Mon
Pete Long

start > run > ncpa.cpl {enter}

any more network interfaces?

what is the exact text form the event log error?
Matthew Ayers

ASKER
There is just the one Network interface (Local Area Connection). The error message is "Windows cannot obtain the domain controller name for your computer network. (An unexpected network error occoured. ). Group Policy processing aborted. "

Thanks.
George Khairallah

It  almost sounds like your TCP stack is corrupt.  
Have you tried resetting it?
netsh int ip reset c:\resetlog.txt

http://support.microsoft.com/kb/299357 

Of course, after you do that, you'd have to reset up your IP config/DNS/WINS, etc ...
Your help has saved me hundreds of hours of internet surfing.
fblack61
Matthew Ayers

ASKER
I have reset the TCP stack but am still receiving the errors. I have attached the relevant output from netdiag /fix. The DNS is definitely registered and running (all the client are able to perform DNS lookups).
netdiag.txt
George Khairallah

Hmm. the 0.0.0.0 DNS looks weird.

A couple of additional items:
- Do you have IPv6 enabled on the server?
- Can you post your full ipconfig /all (unedited) ?
- Do you have the forward and reverse lookups for your server?
- Have you checked the values of your _dc,_SRV,_GC,_kerberos , etc ... do they all look ok ?
Matthew Ayers

ASKER
IPv6 is not installed on the server.
The full output of ipconfig is:
Windows IP Configuration

   Host Name . . . . . . . . . . . . : barnabas
   Primary Dns Suffix  . . . . . . . : stbk.org.uk
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : stbk.org.uk
                                       org.uk

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 00-26-B9-76-57-BB
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 10.253.0.12
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.253.0.1
   DNS Servers . . . . . . . . . . . : 10.253.0.12
   Primary WINS Server . . . . . . . : 10.253.0.12

I far as I can tell all the records in the DNS are correct. I've expanded all the branches and can't see anything that looks wrong. I'm not a DNS expert so there may be something missing, but forward and reverser lookup zones are listed with a correct entry below each.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
George Khairallah

Still very odd.
Alright, moving on :)
Would you please post the one line of the result from:
ping barnabas  and ping barnabas.stbk.org.uk

Also, could you share the result of
netdiag /test:DNS /v > c:\dnstestresult.txt

There's gotta be a pointer somewhere that gets us to an explanation. Most of my research was pointed to having IPv6 enabled and misconfigured, but since you state that it's disabled in your case, then I'm assuming there's a different problem.

By the way , is there a reason your DNS search list is searching in the TLD as one of the search list options? do you have DNS devolution enabled?
Can you check your DNS search list, and make sure that you only have stbk.org.uk in there?
(I'm pretty sure that .org.uk wouldn't do you any good in any situation)
Matthew Ayers

ASKER
Results of the pings:
C:\Documents and Settings\Administrator.STBK>ping barnabas

Pinging barnabas.stbk.org.uk [10.253.0.12] with 32 bytes of data:

Reply from 10.253.0.12: bytes=32 time<1ms TTL=128
Reply from 10.253.0.12: bytes=32 time=2ms TTL=128
Reply from 10.253.0.12: bytes=32 time=2ms TTL=128

Ping statistics for 10.253.0.12:
    Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 2ms, Average = 1ms
Control-C
^C
C:\Documents and Settings\Administrator.STBK>ping barnabas.stbk.org.uk

Pinging barnabas.stbk.org.uk [10.253.0.12] with 32 bytes of data:

Reply from 10.253.0.12: bytes=32 time<1ms TTL=128
Reply from 10.253.0.12: bytes=32 time=-2ms TTL=128
Reply from 10.253.0.12: bytes=32 time=-2ms TTL=128
Reply from 10.253.0.12: bytes=32 time=-2ms TTL=128

Ping statistics for 10.253.0.12:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = -2ms, Average = 1073741822ms

The result of the netdiag is attached. Thanks.
dnstestresult.txt
Screen-shot-2012-10-03-at-16.01..png
Screen-shot-2012-10-03-at-16.01..png
George Khairallah

I noticed that you have an AMD processor. And in researching, a lot of people are mentioning that there is something with the processor drivers that cause this.
Another symptom which I also noticed in your pings, is that you're getting some negative values on the ping. This is not necessarily a bad thing, but could also have something to do with the processor driver.
 I know it's out of left field, but your configuration on the server looks pretty good as far as I can tell.
In this case, I was just going back to the original error that you are getting (UserEnv 1054).

In your case, it's not that the system stopped responding, but I guess it wouldn't hurt to apply these patches :
http://support.microsoft.com/default.aspx?scid=kb;en-us;924441 

By the way, I don't believe you ever posted the full event log entry for 1054. Could you please post that ?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Matthew Ayers

ASKER
I have tried applying the patch, but it says that is is not required as it is included in the service pack.

I have attached the screenshot showing the error report.

Thanks.
Screen-shot-2012-10-04-at-12.08..png
ASKER CERTIFIED SOLUTION
George Khairallah

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Matthew Ayers

ASKER
Thank you for all your help.