Link to home
Start Free TrialLog in
Avatar of gerlis
gerlis

asked on

Windows Updates not wokring on Win 7 Pro

Brand new Lenovo laptop.  Has done most of the updates, but there are about 30 it just won't do (see screenshot).

I have checked the windows update service, all ok
I tried http://support.microsoft.com/mats/windows_update   fixit tool

Lenovo suggest hardware diagnotics, but I don't think that is inthe right direction.

This laptop has been set up as part of a Win server2003 network, so might be a problem with GPO?

All ideas welcomed
Capture.JPG
Avatar of m3mph1s1
m3mph1s1

Very simple fix:

serivces.msc>stop windows update service>c:\windows\softwaredistribution\datastore>delete the .edb file

c:\windows\softwaredistribution\download>delete the contents of this folder

services.msc>start windows update service>run updates and let me know the results.  If there is still a failure please upload copy of event viewer logs
Avatar of Steven Carnahan
Make sure the BITS (Background Intelligent Transfer Service) service is running as well.
Avatar of gerlis

ASKER

Trying it now...
Watch this space..!
ASKER CERTIFIED SOLUTION
Avatar of jcimarron
jcimarron
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of gerlis

ASKER

m3mph1s1: didn't work :-( I'll try to grab the event viewer logs for you. Where do I find them?
pony10us: currently trying with BITS started
right click comuter icon>manage>event viewer>windows logs>

I want application and system logs please.

Also, you can try to run a sfc /scannow from an elevated command prompt too
I just went through this with my Windows 7 Home and in my case there were a number of issues but the one that finally resolved it was missing BITS reg settings.
Avatar of gerlis

ASKER

m3mph1s1

I have renamed them from .evtx extension to .txt as .evtx is not accepted here even within a  zip.

Obviously you'll need to rename them back agin as.evtx files

Thanks
application-logs.txt
system-logs.txt
Avatar of gerlis

ASKER

pony10us: so what did you do to fix the "...missing BITS reg settings"?
In my BITS there were no subkeys so I copied from a known good system the following:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\BITS]
"JobInactivityTimeout"=dword:0076a700
"JobMinimumRetryDelay"=dword:00000258
"JobNoProgressTimeout"=dword:00127500
"LogFileFlags"=dword:00000000
"LogFileMinMemory"=dword:00000078
"LogFileSize"=dword:00000001
"TimeQuantaLength"=dword:0000012c
"UseLmCompat"=dword:00000002
"IGDSearcherDLL"="bitsigd.dll"
"StateIndex"=dword:00000001

These are from my work computer.
gerlis--Since you have not commented I am just wondering if you tried the suggestions in http:#a38455446 .
Avatar of gerlis

ASKER

ran sfc /scannow, no problems found
Avatar of gerlis

ASKER

It might be of interest when it fails it shows Code 643.

See attached screen grab
Capture2.JPG
Avatar of gerlis

ASKER

jcimarron

Just tried your suggestion at http:#a38455446.


http://windows.microsoft.com/en-US/windows7/Open-the-Windows-Update-troubleshooter

 It went through the motions and said it fixed a problem. About to try Windows updates again
Avatar of gerlis

ASKER

So, tried.http://windows.microsoft.com/en-US/windows7/Open-the-Windows-Update-troubleshooter

 It did install one update surprisingly.

Otherwise, still same problem.
Avatar of gerlis

ASKER

jcimarron

I have just tried installing one updates (unticking all the others) asked me to re-start, and it worked!

I am now trying another 2 at once. Crumbs this is going to be tedious!

Also it doesn't mean the original cause has been fixed? Or it may be there is one corrupted update that is affecting the system when run en bloc?
gerlis--  That Capture2.jpg says you have successfully installed 30 of 31 Updates.  Click on View Update History to learn which one did not. You could then try to install from Windows Download Center.

http://catalog.update.microsoft.com/v7/site/Home.aspx   using KB number for search.
Avatar of gerlis

ASKER

Just tried another two at random. That worked OK. Just doing 5 more at random.that worked. Now trying another 10. All OK and the final 12. All worked1

All updates installed successfully. I have no idea what was causing the problem or whether this will recur in the future

It is late here in the UK, almost midnight,  and I need some sleep!  I will check the lepto ptomorrow morning and if all still OK, I'll award the points.
gerlis--Glad to hear the good news.  .NET Framework updates often cause problems
http://support.microsoft.com/kb/976982/en-us
I remember finding something about one update that was causing an issue.  I think it ended with 773 but I installed that one alone like it said and that didn't take care of my issue.  I did see many places that suggested doing them in smaller groups so it sounds like that may have taken care of your issue.

As I stated, I had to dig deeper to find the underlying cause of my issue.  From what I could find I may have had a Malware insfection that caused the problem but when Malwarebytes removed it it didn't fix the update problem. I didn't notice until a few weeks later when Microsoft announced an important update that the rest of my family got and I didn't.

Glad yours is taken care of and that it wasn't as serious as mine.  :)
pony10us--.NET Framework updates often are a problem especially when part of a group.  I usually install them separately.
Avatar of gerlis

ASKER

Indeed I recall I have come across .NET update problems elsewhere before.

This morning the laptop seems fine. Windows U[pdate reports there are no new updates available.


Thanks to all, but jcimarron hit the spot with doing the updates piecemeal.
gerlis--You are most welcome!