Link to home
Create AccountLog in
Avatar of auraorange
auraorangeFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Ubuntu Server 12.04.1 - Monitor Out of Range

Hi All I have installed a copy of Ubuntu Server for the first time and the install was going fine until the reboot towards the end. Now the monitor goes out of range.

I have all the options to press E to edit or C to command line but as you can probably guess I have no idea what to do after that.

Ive looked around on the internet but people all seem to have different variations of this problem.

Thank you
Boot-Options.jpg
Edit-Mode.jpg
Avatar of arnold
arnold
Flag of United States of America image

You need to add vga=791
https://help.ubuntu.com/community/BootText
VGA with the number control the number of bits for color and the monitor resolution.
Avatar of auraorange

ASKER

So when I turn the PC on and press E to edit, I add vga=791 there? then I think F10 to boot?

I read somewhere that by editing at this stage it only fixes the boot up for that time and the next time around have to edit again?

I'll not be able to check this until when I get home tonight.
I did try this but not sure if did it right.

I tried 2 different things:

1) In edit mode I added the line vga=791 below the line "gfxmode $linux_sfx_mode"

2) Replaced the line "gfxmode $linux_sfx_mode" with gfx=791

To help me understand this better, is this a problem with the graphics card or monitor settings?

The graphics card is an old VGA one, so should I replace this?  Alternatively, should I plug monitor into working PC and change settings on monitor and plug back in?
Does your display have the "info" button On screen display that when pressed reports the resolution?
Could you try using VGA=791?
I did try vga=791 as per above comment, however, I was not sure if putting it in the correct place and come to think of it, if this is case sensitive that could be the reason it may not have worked for me.
ASKER CERTIFIED SOLUTION
Avatar of arnold
arnold
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Sorry for the delayed response.  I decided to reinstall the operating system and see if during the install there was any graphics options.  Half way through the reinstall the computer went off.  I swapped power supply for another one and reinstalled  the Operating System again last night and noticed that at the end of the install it advises the install complete, to remove media then reboot.  This did not happen the first time, I turned away from the screen when it advised on screen "finishing installation" and assumed the auto reboot was normal.

This has done me a favour not working as it should have initially as i've picked up more knowledge along the way and been able to play around various grub commands.

All seems to be working fine now, thank you.