Link to home
Start Free TrialLog in
Avatar of rdwolf
rdwolf

asked on

Locked out of Win Small Business Server Essentials 2011 from admin level login

I just get a Dell PowerEdge T110 II with Microsoft Windows Small Business Server Essentials 2011 installed by Dell.  The Server has a Dell Perc S100/S300 hard drive controller that was setup in a RAID 1 (mirroring) config. by Dell.

The problem is that I powered up the server, filled in the info. for the Out of box experience (OOBE) for Server 2011 Essentials, picked Domain name, computer name, and setup 2 users.

The first was admin. level account in which I changed the user name from default "administrator" to a new user name I chose (for better security as that is a good practice to prevent hacking in to known admin login name) and I also chose a non admin user name.

I then just applied all pending Windows updates and rebooted and now I can login to the server with the admin login for the Domain.  I am sure I have it correct.

I also can not login just to the computer using computer name.

I can not login with the non admin user account I created either.

I try booting up using Spotmau Power Suite Golden 2012 suite to reset the password but can not do since the hard drive drivers are not part of that boot able CD and I see no where to load the drivers..

I try boot up with the Dell provided Windows Small Bus. server Essentials 2011 but the repair option does not have the full repair options to get a command prompt (only system restore).

I try booting up with Win 7 Prof DVD and go to the repair option to get to command line that would let me do some options (move Ultiman.exe to Ultiman.exe.bak and then copy Cmd.exe to Ultiman.exe to boot up and then get at command line to get at AD dsa.msc to fix the issue (reset password of admin account and put back Ultiman.exe etc..  - Found sol. when looking) BUT I can not get to command prompt since it only allows "administrator" to login and that account apparently got disabled automatically when I chose a diff. name for admin. level login it seems.

So I am stuck, any ideas, short of doing a full reinstall?  I Just want to get the password of admin reset but can not do it since I can not get at disk drive due to 1) Dell Perc S100 disk drivers are not avail. in boot DVD and 2) It prompts you for "administrator" login which was disabled at command line.

I do have the right drivers to load (on USB stick) and can load for Win install test (but can not get at command prompt).

I was thinking maybe I could remove the SATA hard drives and connect to a USB to SATA converter and go in to change the file (as listed above) to try that fix to get a reset of PW but in a RAID 1 Mirror can I change one drive file? Maybe I can temp. disc. one SATA drive and just change one.. Then after get fixed, reconnect 2nd SATA drive in RAID 1 mirror?

Lot of headache for this... Hoping there is an easy solution.  Next time I will make the password rest disk before booting again...

Thanks
ASKER CERTIFIED SOLUTION
Avatar of netballi
netballi
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of rdwolf
rdwolf

ASKER

Starting over is of course an option (as I mentioned in my original question), but I believe there is a way to get the password reset with out do a fresh install.

Anyone have any suggestions?
Avatar of pgm554
login as the domain admin and from a command prompt
net user administrator /active:yes
you may have to use the renamed one this will bring back the computers administrator account.
Avatar of rdwolf

ASKER

None of the solutions proposed have helped.

1)  From pgm554: The PsPasswd utility does not work for my scenario as described.  Gives errors of RPC server is unavailable.

2)  From ve3ofa: If I can not get to a command prompt,  since I can not login to my Domain admin and the "Administrator" account is disabled, then how could I run this command line to enable the administrator?

3) netballi: Starting over, as mentioned I already knew of that option as I stated.

I can not get to a Windows repair command line option as it requires "Administrator" login which that account got disabled automatically during setup as mentioned.  I have booted up on Win Server 2008 SBS and that is what happens.

I am sure there is a way to get the password reset without a fresh install.  Anyone have any ideas they know will work.

Thanks,
Avatar of rdwolf

ASKER

pgm54: Thanks for the link to 7 free Win password crack/reset.

Do you know if any allow you to load disk drivers for disk controller?  I already have Spotmau Golden Suite 2012 that works well but it can not see my hard drives since the bootable media does not have those Perc S100 drivers as part of the bootable image and I can not yet find a way to load the drivers that let you see the hard drive.

I have question into Spotmau but have not heard back if they have a way as I can not yet find one.

If you know of any of these that have this feature it sounds like a solution.  If not I am still stuck.

Thanks,
You might want to change the port setting on the raid controller or just  use a regular (non raid)sata port on the mobo and see if that works.
You may be able to download a win pe recovery disk from Symantec from a ghost trial and use it to install 3rd party drivers.
If you boot into safe mode the adminstrator account is automatically activated.
Avatar of rdwolf

ASKER

No other solution worked but to start over.
Although this question has been closed, I want to share that I found a tool that, for a price, saved me from re-installing the O/S in a very similar situation. I had a Dell T420 with PERC S110 RAID drives, the usual Linux password reset ISO images would not see the drive as that particular RAID option is Windows software only.

Although I had some reservations, I took a chance with SPower "Windows Password Reset RAID", which uses a Windows PE environment -and it worked, saving me much time and potential grief.