Link to home
Create AccountLog in
Avatar of bigbigpig
bigbigpig

asked on

Backup Exec 2012 - overwriting media on network share

I upgraded one of my media servers from Backup Exec 2010 to 2012 a few weeks ago.  Aside from not being able to back up multiple servers in the same job it's been OK.  But today when my monthly job tried to run it failed.  It runs to a network share but the job held on "queued" partially through because the network disk was full.  The problem is that the job is set to keep data for 2 weeks and most of the backup data (B2Dxxxx.bkf) was from September and early October, well over 2 weeks ago.  I can't find out where to tell the job to overwrite data like in 2010.  It just says "keep for" in the job properties.  How can I make 2012 overwrite my old media?
Avatar of denbosse
denbosse
Flag of Ireland image

Maybe check that the "Media Set" is really configured to keep media for 2 weeks:
To edit media set properties
   1 On the Storage tab, expand Tape/Disk Cartridge Media Sets and Vaults.
   2 Double-click All Media Sets.
   3 Double-click the media set for which you want to view properties.
   4 In the left pane, click Properties, and then make changes as appropriate.

In the "Global Settings for Storage", also make sure you have it configured to overwrite recyclable media before scratch media:
   1 Click the Backup Exec button, click Configuration and Settings, and then click Backup Exec Settings.
   2 In the left pane, click Storage.
Then make sure that "Overwrite recyclable media contained in the targeted media set before overwriting scratch media" is selected
Avatar of bigbigpig
bigbigpig

ASKER

It doesn't associate my disk-backup with any media set.  See my screenshot attached.

The job on the top is FullBackup, which backs up to a pool of 2 Dell RD1000 removable disks.  It treats it like tape and assigns a media set to them.  This job works fine.

The 2nd job shown is "monthly full to network disk".  It backs up to a network share.  You can see in the picture that there is no media set option.  It just says "keep for", and then you can tell it how long to retain data.  In Backup Exec 2010 this was also associated with a media set.
backupexec2012.jpg
OK, I see. Maybe check the second option I suggested - the "Overwrite scratch media ..." one.
Ok I set that option.  So we don't have to wait another month to find out if it worked I'll set the retention period for 1 day and rerun the full backup job tonight.  If it works then it should overwrite anything older than 1 day, which is everything but 1 BKF file in there now.
Yes, hopfully it will do the trick. It would overwrite as many bkf files as it needs to complete tonight's job.
I finally got around to setting the job to keep for 2 days and ran it, but it did not work.  It wrote bkf files until the disk was full, then set the job on "queued".  It's been sitting like that for about 12 hours.  All of the bfk files from October and Nov 4 are still there, not being overwritten.
I'm out of ideas I'm afraid.Make sure you have all the LiveUpdate updates for Backup Exec to make sure you're not facing a known bug. But after that, I'm afraid I don't know.
There is a pending update for SP1a, which keeps failing in Live Update.  I'll install it using the offline installer and see if that fixes it.  If that doesn't work I'll probably call Symantec.  I thought this was a misconfiguration on my end, but it appears that it's not.  Whatever the answer I'll post it here in case someone else has the same problem.
ASKER CERTIFIED SOLUTION
Avatar of bigbigpig
bigbigpig

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Symantec changed the way media is associated in version 2012, and this is now by design.