Link to home
Start Free TrialLog in
Avatar of al4629740
al4629740Flag for United States of America

asked on

"This program might not have installed correctly"

I compiled a program in VB6 and installed it using Inno Setup.  The program runs fine, but an error comes up from windows 7 after the program is closed:

"This program might not have installed correctly"

Has anyone run into this issue and solved it?
Avatar of Luis Pérez
Luis Pérez
Flag of Spain image

Try this:

- Create a text file and name it with the same name as your .exe file, but with .manifest extension. For example, if your .exe file name is "myprogram.exe" then the .text file name must be "myprogram.exe.manifest".

- Inside the "myprogram.exe.manifest" file put this text:

<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
  <application>
    <!--The ID below indicates application support for Windows Vista -->
      <supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"/>
    <!--The ID below indicates application support for Windows 7 -->
      <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
  </application>
</compatibility>

Open in new window


- Place the "myprogram.exe.manifest" file in the same directory as "myprogram.exe" file.

- Run you .exe.

Hope that helps.
Avatar of al4629740

ASKER

wow, that worked!  

Do I have to make them download both these files?
ASKER CERTIFIED SOLUTION
Avatar of shorvath
shorvath
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
So if I just use the current version of INNO, I won't have to change anything?
As per there web site, INNO now support Windows 7 32bit and 64bit.
Make sure you set the PrivilegesRequired directive to the correct level before you recompile your new setup.exe
Where do I set PrivilegesRequired?  Can you show me an example of the code if its in the code for inno?
When you load an INNO setup script (.iss) you will see a [Setup] Header, put it under that

eg.

[Setup]
AppName=YourProgramName
AppVerName=YourProgramVersion
PrivilegesRequired=admin
DefaultDirName={pf}\ProgramName
DefaultGroupName=ProgramName
AlwaysRestart=false
.
.
.
.