Link to home
Start Free TrialLog in
Avatar of SpencerKarnovski
SpencerKarnovski

asked on

Flash MX will not start unless run on an admin account.

Hello.

We have Studio MX installed on a server share, we have users who login that can access the various executables in the directory via a mapped drive which is loaded in their profile.

The permissions on the install directory, located on the server, are correct.

The problem:

The students can run Dreamweaver, Firefoxs from their workstations fine, via the mapped share.  They double click the .exe and the program starts.  However, when trying to run Flash MX, which is in the same folder as Dreamweaver, Firefox, the program will not start.  Double clicking the exe does nothing.   This is the only app in Studio MX folder that they cannot run.

For some reason, this appears to a local permission issue - as all permissions on the directory share are correct.  

For example, we have student D, if I logon to a workstation and add student D to the local machines administrators group, via the manage users applet, then reboot and login as student D, I can run Flash MX - double clicking the .exe starts the application.

But, as expressed before, student D can run the other applications from Studio MX share without having to add them to the local administators group.  So why does Flash MX not run, unless the user account running it is added to an admin group?   Does Flash write to a file when starting up?     It's hard to figure out what I actually need to add permission to, to run the application when its basically installed on another machine.

Thanks.
ASKER CERTIFIED SOLUTION
Avatar of ded9
ded9
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of SpencerKarnovski
SpencerKarnovski

ASKER

Well, it is working now - I added a shortcut to the startup folder.  So when a user logs in, they navigate to the start up folder, click the shortcut to the exe - and it works.

Very strange, how does adding a shortcut to the startup folder bypass a permission issue..
Not sure what kind of security settings are set in environment.

Glad to know your issue is fixed..you can close this question




Ded9