Link to home
Start Free TrialLog in
Avatar of brandonpf
brandonpf

asked on

Periods Rendering As Commas

Kind  of a strange deal.  I printed a document to a document management software program (its called FileCabinet CS from Thomson Reuters).  When I view that document on my Windows XP machine via that program, everything renders correctly - the periods appear as periods.  When I access that program via our company's terminal server (Windows Server 2008 R2), the periods appear as commas.  Any ideas about why that may be happening and how to fix?  My guess is that certain fonts are missing on the newer server but I don't know where to look for that.

Thank you,
Brandon
Avatar of Joe Winograd
Joe Winograd
Flag of United States of America image

Hi Brandon,
If the issue occurs on all commas and periods, even the ones in text, then I don't know what's wrong. But if it's occurring only in numbers, then it may be the regional/language setting (some parts of the world use commas in numbers where other parts use periods). Go into Control Panel, then Regional and Language Options, and check the settings. Regards, Joe
Avatar of brandonpf
brandonpf

ASKER

Thanks for the reply, not happening with just numbers...here's an example:

If you were to look at this document:

http://www.irs.gov/pub/irs-pdf/f1040.pdf

All of those periods that stretch from the text on the left side (in that Income section) to the right side of the space where the numbers go are appearing as commas.
You may be right about fonts being the issue. Are you looking at that file with Adobe Reader? If not, let me know how you're viewing it; if so, go into Preferences>Page Display and un-check the [Use local fonts] box. Also, let me know what happens when you view it with a different PDF reader/viewer, such as the excellent freeware products PDF-XChange Viewer and Foxit Reader:
http://www.tracker-software.com/product/pdf-xchange-viewer
http://www.foxitsoftware.com/downloads/

Regards, Joe
The documents are being viewed by the native document viewer of the software.  I'm not sure what format it puts them in but these documents have been electronically printed to FileCabinet CS and then are viewed in there.  I took a screen shot to show you what I see.  A couple things: 1) apologies for saying they appear as commas, they are actually appearing as tildes (~) 2) it is strange to me that certain rows in that screen shot render correctly as periods and others render incorrectly as tildes, that's why I chose this particular part of the document to screen shot.  Not sure what is different about those different lines.
periods.jpg
Not that it matters, but the screenshot is of a different document from the PDF you posted earlier (i.e., the JPG's lines 1-10 don't match the 1040's lines 1-10, so they must be different IRS forms). In any case, my guess is that it's a problem with FileCabinet CS...either with its native document viewer or with its print driver that sends the docs into the system. I'm not a FileCabinet CS user, so can't help with that. Let's hope some other EE experts with FileCabinet CS experience jump into the question. In the meantime, I suggest trying FileCabinet CS support:

https://cs.thomsonreuters.com/ua/fcs/cs_us_en/get_help/using_online_help.htm?Product=fcab

and its Community Forums:

https://cs.thomsonreuters.com/community/forums/default.aspx

Regards, Joe
Thanks, Joe.  I intentionally posted a different screen shot than the above because I thought it was peculiar that a few of those lines rendered correctly.

The thing that makes me think this is a server issue is because if I open up FileCabinet CS on my Windows XP machine, everything renders perfectly fine (I even tried it on our old terminal server - 2003) and it rendered perfectly there as well.

Brandon
Good point...sounds like an issue with Windows Server 2008 R2. Maybe it's a compatibility issue, so one idea is to enable Compatibility Mode on FileCabinet CS. Find the FileCabinet CS executable, right-click, select Properties, click the Compatibility tab, check the [Run this program in compatibility mode for:] box, and pick Windows XP (SP2 or SP3, depending on what you have on your XP machine where it works). Regards, Joe
And you can also try compatibility mode for Windows Server 2003, since you say it's fine there, too.
ASKER CERTIFIED SOLUTION
Avatar of brandonpf
brandonpf

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Closing this question as the troubleshooting we tried did not work but its not a huge matter that I resolve this issue.