Link to home
Create AccountLog in
Avatar of LifeFlight-IT
LifeFlight-IT

asked on

SharePoint 2010 search service is failing, Event ID 6482

Recently our SharePoint server started throwing errors.  Did some investigation and found that it was the search service instance that was causing it.  Tried all sorts of things to get it to work but finally decided to just remove it and add a new search service.  Unfortunately, I was unable to completely remove the service.  It would just timeout after quite a while.  I was able to add a new search service so the users are happy as they can still search on the site.  I would still like to get this figured out as the server is throwing 4 different errors every few minutes.  Which I am sure is not helping the stability of the server or site.  Any  help would be appreciated.  Thanks.

Info about our SharePoint 2010 setup:
Stand alone server hosting both SQL 2010 and SharePoint 2010
Server is a VM with 2008 R2 on it
______________________________________
Errors that we are seeing, in order as they come:
67,
Could not access the Search database. A generic error occurred while trying to access the database to obtain the schema version info.

Context: Application '927288d2-01d2-437d-bc18-ba6bcbdc2f82'

Details:
      Unspecified error
 (0x80004005)
______________________________________________
6482,
Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (230157d4-ad8e-4cd9-837b-bdc0bbe2b8dd).

Reason: The search application '927288d2-01d2-437d-bc18-ba6bcbdc2f82' on server (SharePoint Server) did not finish loading. View the event logs on the affected server for more information.

Technical Support Details:
System.Runtime.InteropServices.COMException (0x80070015): The search application '927288d2-01d2-437d-bc18-ba6bcbdc2f82' on server (SharePoint Server) did not finish loading. View the event logs on the affected server for more information.
   at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
   at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)
_________________________________________________________
6398,
The Execute method of job definition Microsoft.Office.Server.Search.Administration.IndexingScheduleJobDefinition (ID 815c99a2-ef67-4d15-8f68-70fc32db756e) threw an exception. More information is included below.

The search application '927288d2-01d2-437d-bc18-ba6bcbdc2f82' on server (SharePoint Server) did not finish loading. View the event logs on the affected server for more information.
____________________________________________________________
Avatar of Rajendra Shekhawat
Rajendra Shekhawat
Flag of India image

Hi,

Try delete old search service application using powershell / stsadm.

Following below referenced articles for help -

http://donalconlon.wordpress.com/2010/08/27/deleting-the-search-service-application/ 
http://alpesh.nakars.com/blog/delete-sharepoint-2010-search-service-application/ 

I hope it helps.

Cheers.
Rajendra Shekhawat
Avatar of LifeFlight-IT
LifeFlight-IT

ASKER

Rajendra,

Thanks for the quick response.  I have tried both of these already.  The powershell command timed out like when I used Central Admin and the stsadmin comes back almost immediately with a "Command Line Error".  I apologize, I should have mentioned this in my original post.  Any other suggestions?  

Thanks
Hi,

Please check SharePoint Logs to find exact reason for Powershell timout or stsadm 'Command Line Error'.

Cheers.
Rajendra Shekhawat
Rajendra,

Here are the errors I am receiving when using stsadm:
----------------------------------------------
Error:
11/06/2012 14:45:06.44      STSADM.EXE (0x14CC)      0x1E18      SharePoint Foundation      Unified Logging Service      b8fx      High      ULS Init Completed (STSADM.EXE, onetnative.dll)      
11/06/2012 14:45:06.44      STSADM.EXE (0x14CC)      0x1E18      SharePoint Foundation      General      0000      Medium      Microsoft SharePoint Foundation log file      
11/06/2012 14:45:06.46      STSADM.EXE (0x14CC)      0x1E18      SharePoint Foundation      Topology      apzn      Medium      Diagnostics settings: 32768      
11/06/2012 14:45:06.56      STSADM.EXE (0x14CC)      0x1E18      SharePoint Foundation      Performance      nask      Unexpected      An SPRequest object was not disposed before the end of this thread.  To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it.  Due to flags specified at object creation, this will not be freed until processed by garbage collection.  Allocation Id: {15A779E5-A6A4-4681-8DEA-AFFF4ABD2C4B}  To determine where this object was allocated, set Microsoft.SharePoint.Administration.SPWebService.ContentService.CollectSPRequestAllocationCallStacks = true.      
11/06/2012 14:45:06.56      STSADM.EXE (0x14CC)      0x1E18      SharePoint Foundation      Unified Logging Service      8wsw      High      Now terminating ULS (STSADM.EXE, onetnative.dll)      
-----------------------------------------------------------------------------------
On a side note, I copied the vm into dev for testing last night.  This morning, I decided to try the stsadm on it again.  It worked flawlessly.  Tried it again on production and got the same error as above.  

Any ideas?

Thanks!
Hi,

Error displayed in the log provided by you is a generic exception and not related to errors you are getting. Please run the command and get the logs at that specific point of time based on the correlation id.

Cheers.
Raj
Raj,

When I run the stsadm command to remove the object, I can't find anything in the log that has the ID of the object I am trying to remove.  Is there another way I can find the info you are requesting?  Thanks.
ASKER CERTIFIED SOLUTION
Avatar of LifeFlight-IT
LifeFlight-IT

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Microsoft was the only way to go on this one.  At least they didn't charge me as it only took a few minutes to fix.  Nice.