Link to home
Start Free TrialLog in
Avatar of soughtseven103
soughtseven103

asked on

IDE to SATA Adapter for DVD-Rw

I recently bought 2 cheap IDE to SATA adapters from eBay.  I have a CD-ROM drive that uses IDE and a motherboard that uses only SATA, no IDE.  So I got this thing hooked up to my DVD drive and it doesn't work.  It requires a 2-pin molex for power and a sata cable to connect to my motherboard.  I was looking in bios to see if there's a setting or not but I can't find any.  Also, I can't see it under My Computer.  Please help!
Avatar of Ken Butters
Ken Butters
Flag of United States of America image

The jumper for Master/CS/Slave doesn't apply to SATA... but I've read in other forums where setting the drive to "CS" or Cable Select will allow it to be recognized by the BIOS.

However... I'm surprised at your power connector... most IDE drives require a 4 pin Power connector ... not a 2 pin.

If changing the jumper on the IDE drive doesn't work.. What are the makes/models of your IDE drives?
Avatar of soughtseven103
soughtseven103

ASKER

I think it's either a Samsung of HP DVD-RW.  It might be 4 pin I am not really sure I remember correctly.  I tried that cable select jumper setting and it did not work.
when you first connect the drive... try and see if you can listen to it or feel it by touch... to see if it spins up.... usually they will vibrate with enough force that you can feel it or hear it over the fans....

That would at least tell you if it is getting power.  I would confirm that you have plugged in the 4 pin molex power connector to the dvd drive... if you haven't then it won't turn on, and that would explain why it's not being recognized.

You said something about a 2 pin connector... there is a 2 pin connector that connects from most IDE DVD/CD players to the mother board, but that is usually a 2-PIN CD/DVD Audio cable... not power.

I found an image for you to review... it shows where the 4 pin power connector is on the back of most dvd players as opposed to the audio cable.

Compare that to your setup and verify that you have power/audio/IDE cable connected properly.

Note... I also attached a picture of the molex power connector... you should have one that looks like that attached to the back of the DVD player.
dvdback.jpg
4pin-Molex-female-connector.jpg
Well what's funny is the drive itself actually opens and sounds like it's reading the dvds I put in it but nothing shows up in windows.  So that's why I am thinking it's a BIOS or something problem.  What I have is right.  I do have the 4 pin molex to the drive, and a 2 pin molex to just the adapter part I guess needs some power for the light or something.  I just need to know why windows isn't recognizing it.  Everything is setup right.  They also said you can put the IDE controller in upside down and I checked that to make sure it's right and still nothing.
I had this happen before with a laptop or something and I think I had to manually pin it to the map network or something.
actually you had a bad idea bying the adapter - for the same price, you had a Sata DVD drive, and no problems
that said, what adapter is it? post a link to it plse
i see on this link no supported OS, like W7, w98...
look into device manager, and post the errors in there; it looks like it's not installed
did it come with installation software and in structions?  i guess not...
Question on your power connections...

I was reading a forum where they said this was a common problem for not recognizing the drive.

The adapter needs it's own power plug.
The DVD drive needs it's own power plug.

Are you using 2 plugs from your PC's power supply... 1 to the IDE/Sata adapter and the other to the DVD drive?
Yes the power connections are fine.
Have you set the SATA port to IDE or Compatible in the BIOS?
Also I have to set my drives to MASTER or MASTER with NO SLAVE (if it needs that setting) for the IDE hard drives or optical drives to work on the SATA port.
are there any errors in device manager?
post apic ture, or post the erros plse
there is no errors, just doesn't show up under my computer.  no errors in device manager.  i have checked the bios settings and i dont think i have a jumper on the drive at all.  i tried the master position before but it didn't work.  i tried all the jumper settings i think.
ASKER CERTIFIED SOLUTION
Avatar of _
_
Flag of Bahamas image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yes, best test all the parts separately : adapter, cables, and device
Yeah I think either the Optical Drive or Adapters are bad.  It's probably the drive that is bad but it could be the very cheap adapters.  I will just take it out, didn't really need it I just thought 2 was cool.
Thank you much.   : )

>> ...didn't really need it I just thought 2 was cool.

I agree. Being able to set an IDE drive on the desk and plug it to a SATA cable, makes cloning/testing them soooo much easier.   ; )