Link to home
Start Free TrialLog in
Avatar of fxr1216
fxr1216Flag for United States of America

asked on

Different results same group policy

I am having group policy issues on Windows 7 machines. I have narrowed it down somewhat but I am still having issues. Here is the best example of the problem. I have two win7 machines both in the same OU. Both on the same subnet. When I log into one machine I get 5 mapped drives (as I should) on the other I only get one. When I run run gpresults I get results for the 5 drives even though I only get one. One final note, I have no problem accessing the drive manually so its not a permission problem. Any ideas would be helpful
Avatar of Gabriel Clifton
Gabriel Clifton
Flag of United States of America image

Are the mapped drives applied by GPO or script?
One possibility is that some of the computers are inundated with massive GP settings and it can be common for the computer to need multiple gpupdate and reboot to get them all, another is that some computer could be applying the GPO or scripts before the computer fully initializes the network card and obtains an IP Address.
Avatar of arnold
The profile is local or roaming? Sounds like local.

Use control keymgr.dll on the one where the five do not appear to make sure there are no saved credentials with old passwords that prevent the mappng.

Are you able to manually map the drives after logon?

Are you able to acces the same way the drives are mapped?

\\servername\sharename
\\doman.local\sharename
\\domain\sharename?

Check the servers where the share is, to make sure there are no stale sessions from the win7 system.
Avatar of fxr1216

ASKER

I believe the problem is in the way the grop policy was created. Almost all the mapped drives are linked to all users and have security filters to give the drives to the appropriate groups. I dont think this is good practice so I am doing some serious rearranging of the OUs. I am also changing from logon scripts to preferences to map the drives.

I am hoping this will solve the problem
If the issue is isolated to the user/system, the means by which you deploy the resource might not solve the problem. The issue might be a stale record on the server where the share resides for the user.

Check the share sessions when the users are not logged on to see whether they are still reflected as having a session. Ten look at what resources these users have open.  After confirming that these users are not logged in on the system from which the connection is indicated, close the session on the server and this should fix the issue.  Often running a net use X: \\server\sharename will through out a system error 53.  There might be other explanations as well. This error points to a stale session when you get an error for running the prior example and then no issue by using the IP instead of servername.
Avatar of fxr1216

ASKER

The issue is not isolated to a user or system. I work at a school and I am having the trouble all over the place. The students signing in and 2 out of 3 get their mapped drives. They switch to another machine and it works fine. Someone else logs into their machine and it doesn't work again. I have beenable to isolate one user and one machine (the example i started with). However on that same machine another user can log in and get all the drives.
Do the shares allow offline access.
Do the users have roaming profiles?
What error does the user get when trying to map the drive in a cmd window using net use?
Avatar of fxr1216

ASKER

I do not believe the shares allow offline access. If I run the script from the command prompt, the drive maps successfully. We do not use roaming profiles

Thanks for all your help
So a user upon login does not get the drives mapped, but you get the drives mapped by running the GPO based login script? Trying to see whether the issue with the login script is that it does not apply to the user.
On the system that is having this issue, try refreshing the group policies, gpupdate /force.
Avatar of fxr1216

ASKER

I have forced the update but no luck.  If I run gpresult from the client it says that it got the drive even though the drive does not appear. I thought it was a slow link so I enabled that group policy and set it to 0. This did not have any effect
What about net use X: \\server\\sharename?
What error is returned?
Avatar of fxr1216

ASKER

It works fine. The command completes successfully
Have you tried login script to map the network drives even as a fail safe

if not exist M:\ net use M: \\server\share

it never hurts to have a fail safe
Avatar of fxr1216

ASKER

I will try but I am also having the same problem with drives defined in preferences
What is the action you have in map drive policy: create, replace, update
if you have it on create try replace or update we use replace.
Avatar of fxr1216

ASKER

I use update but I will try using replace.

I  used if not exist M:\ net use M: \\server\share in the login file to no avail. (it ran successfully from the command prompt)
ok, I just looked at out backup login script:

if not exist "M:" net use M: \\server\share
ASKER CERTIFIED SOLUTION
Avatar of arnold
arnold
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial