Link to home
Start Free TrialLog in
Avatar of CarlMGregory-MM
CarlMGregory-MM

asked on

Window 7 64 File Copy Issue with large files

Windows 7 64 Bit will not copy large files, it errors out every time.  The error is:
An unexpected error is keeping you from copying the file.  If you continue to receive this error, you can use the error code to search for help with this problem.
Error 0x800900006: Invalid Signature

Am not running Symantec Endpoint.
Avatar of John
John
Flag of Canada image

How big? I can copy a 45 Gb file without any issue at all. Let us know what size it is erroring out on?

What are you copying it to?  Bigger that the FAT allowance on most USB Keys? That will cause an error.

 Thanks, ... Thinkpads_User
Avatar of CarlMGregory-MM
CarlMGregory-MM

ASKER

Copying to NTFS drive, to the desktop.
The file is 75megs.
I just now tried it, it copied without any error.  Tried it a second time, got the error.
Just in case it is relevant;

* Copying from a Windows 2012 Standard server running atop VMware ESXi 5.1.
* Tested this on a Windows XP machine, not part of domain, works.  Tested on a Windows 7 machine, not part of domain, works.  Tested on another Windows 7 machine, is part of domain, works.  It seems to only be this computer.  I formatted and reinstalled the OS, I even tried a new network card.
If it is working on so many computers, than the server appears to be fine, the file (very small at 75MB) appears to be fine (although check it specifically for viruses just in case).

So if on the one problem computer you have reinstalled the OS and it is still a problem, but not always, then do two things:

1. Check your memory for sure. You could be having a memory error.
2. Check your hard drive for errors. It could be failing but allowed you to re-install.

If seems to be a hardware error at this point.

.... Thinkpads_User
I just setup a new computer, it ran vista - I did a clean install of Windows 7 on it.  Join'd it to the domain.  Tried the file copy, it get's the error.  

I went back to one of the Windows 7 computers that is part of the domain that did not get the error (when I tried them the other day) and tried a copy.  Now they get the error too.
I had the same issue with Win7 Pro 64 bits running on my DELL Optiplex. the differences is mine not just happened on copying file, sometimes when browsing web it is also pop up with this error and when I open Windows Explorer, i encountered the same problem.

So I tried to format and re-install my Windows, a few days later I still encounter this problem, so I start doing my hardware testing and finally I found one of my computer 2GB RAM seem to be the root cause of the problem. after changing that RAM everything become smooth and no more error.

so my suggestion is instead of looking on software issue, you should pay some attention to the hardware, it might be caused some unexpected error.

thanks
You are starting to suggest many computers with the same problem.

So look also to checking the memory on the physical server and also consider replacing the NIC on the physical server (the server that is running ESXi). VMware itself uses the physical hardware but otherwise its virtual hardware is very reliable.

Take a problem computer, connect up a USB hard drive with lots of space and try copying a file multiple times to this USB hard drive.

You need to determine if this is a workstation problem (and if so, why so many) or if it is a server problem.

... Thinkpads_User
Alright, just tested them all right now.  Here are the results:

Dell Dimension 5150
Windows XP
Not part of domain.
No error.

Dell Vostro 1720
Windows 7
No Domain
No Error

Dell Vostro 220s
Windows 7
Is part of domain.
Error

Dell Vostro 230
Windows 7
Is part of domain.
Error

Dell Vostro 220s (another)
Windows 7
Is part of domain.
Error

Dell Optiplex 780
Windows 7
Is part of domain.
Error

Dell Optiplex 380
Windows 7
Is part of domain.
Error

Seems that if they are part of the domain they get the error.
It would appear you have a server hardware problem or server network connection problem. It does not seem likely so many computers would start this problem all at the same time.

Check your Active Directory settings and also DCHP settings that everyone is allow in at the same time. You could have some limits on domain usage and times and number of DHCP users.

But it looks more like a server or switch hardware problem.

I assume your virtual machine is connected to the host by Bridged Networking. It should be.

... Thinkpads_User
How could it be a hardware issue if it works for those not part of the domain and doesn't work for those that are?  They both go over the same hardware.

As for 'check your settings' -- not sure what settings to check.  I have tried checking everything I can think of.  Even unlinked all the GPO's, that didn't help.
First, I have not seen a file copy error like this for a small file (75Mb is very small) on a properly running server.  So it is best not to exclude possibilities because they don't seem likely.

Domain:  Does your server guest machine have enough CAL's to support all the machines. Is one stopping for a split second, getting kicked out by the next machine and unable to connect so that the file copy cannot complete?

Server: Memory errors are random. I would surely check the physical server memory.

Number of users: Somewhere in the network or server system, is there a limit on the number of users.

How many machines in total use this server?  

In Active Directory, look through each user and compare settings. There is a Tab for when users are allowed to access.

How many Switches do you have in this setup and might you replace a switch.

It does not seem to be a workstation problem (unless you can assure yourself they all went bad), and so it must be a server (or possibly a switch) problem. Switches go bad and not necessarily OFF bad.  ... Thinkpads_User
ASKER CERTIFIED SOLUTION
Avatar of CarlMGregory-MM
CarlMGregory-MM

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
You would think it should happen to all computers. My consulting computer is not on any domain although I help clients with several servers. I have not seen that kind of behaviour at all.

I re-enabled the Large Send Offload options and tested it again on a Windows 7 Professional computer that was not on the domain - it got the error

I think it is a matter of timing. If traffic drops off, there may be fewer problems; if traffic increases, there may be more problems.

I was sure it would be a server (or switch) issue and it was a server issue. I need to look at some servers later this week, but I don't think any of them are sending jumbo packets, so I am not sure what might have happened here.

.... Thinkpads_User
Works great, no further issues.