Link to home
Start Free TrialLog in
Avatar of 3Si_pnewman
3Si_pnewman

asked on

Publisher 2010 Character Encoding - UTF-8

Hi,

I am trying to set up a mail merge in MS Publisher 2010 with a data source that uses UTF-8  character encoding.

Once I have specified the data source the "Mail Merge Recipients" screen is not able to identify the columns (please see the screenshot) however if I use Notepad++ to change the format to ANSII everything works fine.

Is there a way to tell Publisher to use UTF-8 encoding?

User generated image
Thanks
Avatar of jaynee
jaynee
Flag of Australia image

I know that it's used for publish-to-web rather than reading data sources, but have you tried setting the web options to UTF-8 and turning off "Use default encoding"?

What was used to create the data source? If it doesn't infringe privacy/confidentiality can you use "Attach File" to upload one of those data.csv files with just a few lines in it?
ASKER CERTIFIED SOLUTION
Avatar of jaynee
jaynee
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
It's also probably worth trying putting a file called schema.ini in the same folderas the data source, with the contents:

data.csv
format=csvdelimited
colnameheader=true
characterset=65001