Link to home
Start Free TrialLog in
Avatar of PaulJohannesMarais
PaulJohannesMaraisFlag for South Africa

asked on

URL Links in SharePoint 2010 workflow

I made a change to my alternate access mappings in SharePoint to get my searches working.  Basically I made the default zone a non-SSL site.  My links that I have in emails that are sent from a workflow are not working anymore.

My setup is as follows :

Default is http://external_FQDN (have a DNS zone which resolves to internal IP addresses)
Intranet is http://netbios_of_SharePoint_server
Internet is https://external_FQDN

I have setup the Cross Firewall Access Zone to the Internet Zone.  I have used the Lookup %Workflow Context:Current Utem URL% in the email.  This works internally but not externally.  The link shows that it is trying to connect to the http://external_FQDN not https://external_FQDN.  Once it fails if I add an 's' in the URL it works.
Avatar of PaulJohannesMarais
PaulJohannesMarais
Flag of South Africa image

ASKER

Resolved it myself
ASKER CERTIFIED SOLUTION
Avatar of PaulJohannesMarais
PaulJohannesMarais
Flag of South Africa image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial