Link to home
Start Free TrialLog in
Avatar of rgb192
rgb192Flag for United States of America

asked on

port 587, what are the other settings

I have used phpmailer and gmail on port 465 worked
the standard settings for 587 on the phpmailer() website result in timeout error
http://phpmailer.worxware.com/index.php?pg=examplebgmail


I have a similar mail question but
this question specifically for getting gmail and phpmailer() to work with port 587

please tell me what I should use for
smtpauth
smtpsecure
mail->host

  
$mail->IsSMTP(); // telling the class to use SMTP
$mail->SMTPDebug  = 2;                     // enables SMTP debug information (for testing)
                                           // 1 = errors and messages
                                           // 2 = messages only
$mail->SMTPAuth   = true;                  // enable SMTP authentication
$mail->SMTPSecure = "ssl";                 // sets the prefix to the servier
//$mail->SMTPSecure = "tls"; 
$mail->Host       = "smtp.gmail.com";      // sets GMAIL as the SMTP server
$mail->Port       = 465;                   // set the SMTP port for the GMAIL server
$mail->Port       = 587;

Open in new window

ASKER CERTIFIED SOLUTION
Avatar of hielo
hielo
Flag of Wallis and Futuna image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of rgb192

ASKER

did not work at first, now
both work on the server I am testing

thanks