Link to home
Start Free TrialLog in
Avatar of Julian123
Julian123

asked on

Custom calendar fields not appearing in the new and edit forms in SharePoint Foundation 2010

I have added some custom properties to a calendar webpart in SharePoint foundation 2010 (this is the companyweb site from Small Business Server). If I click an existing item on the calendar, the read-only form that pops up shows those new properties. However, if I click the "edit" button I do not see the new properties so I cannot fill them in. Also, if I click the "new" button to create a new calendar item, I cannot see those properties.

How I make them show up in all views?

Thanks!
Avatar of Rajendra Shekhawat
Rajendra Shekhawat
Flag of India image

Hi,

The "problem" is that every list and library is bound to a content type. Unfortunately Microsoft hided that by disabling "Allow Content Type Management" by default. When you create a new field like you did it is added to the list but not bound to the content type the list depends on. If you go to the list settings and enable Content Type management you can add the new "list fields" to the content type and you will see them.

Best approach for adding fields to a list template is to create your own fields and add them to a content type. Then you create the list template based on this content type (easy with VS) or add this content type to the list too.

Please follow steps in below article to add fields to content type -

http://ranaictiu-technicalblog.blogspot.in/2011/06/sharepoint-2010-customize-sharepoint.html 

I hope it helps.

Cheers.
Rajendra Shekhawat
Avatar of Julian123
Julian123

ASKER

Thanks, but that didn't work. I followed the instructions to add a new column to the "event" content type. Once I did that, I could see the new column in the display form but not the new or edit forms, so I'm still having the same issue.
Avatar of Jeffrey Kane - TechSoEasy
How exactly did you add the additional properties?  Because in order for the field to automatically show up on all three of the Calendar List's web part forms (New, Display & Edit), you should use the "Create Column" button on the Calander Tools > Calendar > Manage Views tab.

User generated image
FYI, when you use the Create Column button it has an option to "Add to all content types" which is checked by default.  So the info that Rajendra provided above is not valid.

Jeff
TechSoEasy
User generated imageUser generated imageThanks very much for your help, Jeff. I tried that and could not get it to work. I've attached a screenshot of what I did. Please note that I'm using SharePoint Foundation 2010 but have not updated the site to the 2010 look and field since it is not yet approved by my management. However, I do think I did the closest approximation of what you suggested. Could you please let me know if I'm doing something wrong?

Thanks!
And just so it's clear, when I did the above I had the same symptom I saw before. I could see the new column in the display view but not the edit or new views.

Thanks!
ASKER CERTIFIED SOLUTION
Avatar of Rainer Jeschor
Rainer Jeschor
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I'm confused... you say you are using SharePoint Foundation 2010?  What version of SBS are you doing this on?

Jeff
TechSoEasy