Link to home
Start Free TrialLog in
Avatar of RFloyd30
RFloyd30

asked on

Windows SBS 2011 - Change default Exchange domain

I have a Windows SBS 2011 setup.  The company has about 5 email domains and all is working okay receiving email on these domains plus activesync for smart phones and OWA/RWW is all working well.

I changed the default Exchange domain from the .local address to the main .com address and caused major issues with activesync.

Activesync users on iPhone and droids could receive messages but could not receive the body of the messages and could not send emails from the phones.  Once i changed the default domain back to the .local all started working correctly.

I did this in the EMC and simply right clicked in the accepted domains tab and chose set as default.

I've never done this that I can remember on a full Exchange 2010 setup so I'm not sure how this would affect that environment but in SBS should I run the fix my network wizard or do something to allow me to change the default domain.

I need to do this because of a foreign connector fails unless the the default domain is the .com domain.

Thanks for any input.
Avatar of Exchange_Geek
Exchange_Geek
Flag of India image

It should be the same with a bit of twist.

Read screenshot wise how-to

http://blogs.technet.com/b/sbs/archive/2011/04/13/how-to-configure-sbs-2011-standard-to-accept-e-mail-for-multiple-authoritative-domains.aspx

Let me know if you have questions.

Regards,
Exchange_Geek
LOL @RadhaKrishnan: It was being referred to as Exchange domain- email address policy NOT Active Directory Domain.

Regards,
Exchange_Geek
Duh !!!! Aren't we talking about Exchange domain or was it being referred to for Active Directory?

Regards,
Exchange_Geek
RFloyd30: What i guess your referring to is Email policy so ideally you shouldnt be messed simply adding new ones or creating new ones should be how you should proceed .... if you can share your feedback with Experts we can surely help you better.

Domain Change with SBS isnt a good way to go can mess up all applications.

- Rancy
Avatar of RFloyd30
RFloyd30

ASKER

Thanks for the posts -

Exchange domain - IE Accepted domain.  Not the AD Domain.

I know how to perform this change.  But the problem was that when I did the procedure it broke the activesync.  As soon as I changed it back, the Activesync fixed itself with no other issues.

The system was installed replacing SBS2003 and all domains plus activesync were in place in old domain so this new install (completely built new, no swing method) was setup with the same Exchange accepted domains.  
The owner does not like the recpient policy changed because he does not want all users to have all domains for email.  So the main.com is the main Exchange domain which includes all users.  But they have about 4 other business units and these domains are all accepted domains but the recpient policy was not changed because he does not want all users to have these domains.  So we add them manually.

We have a fax server (Zetafax) that delivers email to recipients on exchange for inbound faxes.  With the domain set to the default of the .local, exchange gets the message no problem but when trying to deliver it gives a 550 5.1.1 error - i can see in message tracking.  But if you change the default domain to .com and restart - then this fax server can deliver the messages or Exchange does not error.  They say its Exchange...i had to change it back to .local because of activesync issues.

Thanks again for any input.
Is this Fax system local to your environment Or remote?

Regards,
Exchange_Geek
Local - it has an install as a foreign connector and uses pickup and drop folders.  There is no receive connecter installed that can be configured.  It does put the email in the pickup folder and exchange grabs it like it should but errors with the 550 error on routing, unless the above described steps are done.  Its a member server in the domain.
Thanks
Understood, so here is the deal, when you convert the domain to accepted domain - internal, are you changing the email address policy too?

Rem: you can have multiple accepted domains, but you may not have those email address as primary email address for all (you can filter users, basis need - but that's not to be discussed here)

Regards,
Exchange_Geek
No changes except to the "default" domain.  No recepient policy changes.  See the picture attached.  If I simply right click the Windows SBS external domain and make it default, the fax server works and the activesync breaks.  Change it back to like it is now, the fax server 550 errors and the Activesync works.

There are two email policies - the highest priority is the domain.com and the lowest is domain.local.  The other domains are added to their respective users, uncheck the use recipient policy and then set to default for that user, if that helps.

Thanks
picture.jpg
When you state Active Sync breaks - have you tried to reconfigure your account on A/Sync phones are worked with it?

How about you test A/Sync on https://testexchangeconnectivity.com and provide results post-change and before-change?

Regards,
Exchange_Geek
The activesync works partially - they get the messages but cannot read the body/content of the emails.  They cannot send either.

The remote connectivity analyzer works like a charm.

We have even deleted the accounts and recreated on an iphone - creates fine and syncs but you cannot see the body.  

They could see attachments but not in every case.

They get a message on the phone - something like "the body of the email has not been downloaded from the server"

Very strange...  

Again, once i change the default domain back to .local - all is good.
How about you keeping both.local and .com as accepted domains?

Regards,
Exchange_Geek
don't know what you mean?  Please explain.  All the domains are accepted domains.  The DEFAULT is the problem.
That's odd. Is it possible to share the logs when FAX is getting 5.1.1 errors please?

Regards,
Exchange_Geek
will do.  it will be later tonight.

What I really need to know is why changing the default accepted domain breaks the activesync.
That's difficult to state, I could offer to read the IIS logs, but i doubt that'll have anything worthwhile in it.

Regards,
Exchange_Geek
ASKER CERTIFIED SOLUTION
Avatar of Exchange_Geek
Exchange_Geek
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thanks - that looks to be the solution which i will implement tonight.  This is the exact issue that we are having.  Not sure if you read the article but I had to read it a couple of times to understand what it was trying to convey.  Its the actual NAME of the accepted domain that has spaces, not the actual value which is the domain.com name itself.

I will report back tonight!
That was it - perfect.  I'm wondering how you found it.  I usually pat myself on the back to be able to find difficult articles to help me solve problems but this one I did not see.  Any help on that would be nice :)...

But this article is 100% on and described my problem exactly.  If you click the link in the article at the bottom, it will take you to a SP1 link that gives a little more detail.

I would assume that this would not affect normal Exchange 2010 although I do not know for sure.  The wizard in  SBS creates the external domain and thus the spaces.  Now both work with the default domain being the .COM address.

Thanks again!