Link to home
Create AccountLog in
Avatar of detox1978
detox1978Flag for United Kingdom of Great Britain and Northern Ireland

asked on

WSUS: Not yet reported

Hi All,

I recently setup a WSUS server.

I accidently deleted the default IIS site before installing, but it gave me the option to create a new site during the WSUS install, so think it should be ok.


Client computers are poping up in the WSUS console, but they all say:
Not yet reported

I've run "wuauclt /reportnow" from the client machine, with no joy.


Any suggestions?
D
Avatar of Member_2_6492660_1
Member_2_6492660_1
Flag of United States of America image

try wuauclt /detectnow /reportnow

or wuauclt /reauthorization /detectnow

I have moved my WSUS from one server to another in the past and found it just took a few days to get all computers back in sync.

Are all your computers/servers showing?
Avatar of detox1978

ASKER

Tried the first one a couple of hours ago without any luck.   Just run the second, so will let you know how it goes.

All computers are showing up correctly and in the correct container.
No luck with the second one.

Any other suggestions?
Avatar of Sarang Tinguria
follow below link and download wsus client dignostic tool which will tell you what exactly your issue is

http://download.microsoft.com/download/9/7/6/976d1084-d2fd-45a1-8c27-a467c768d8ef/WSUS%20Client%20Diagnostic%20Tool.EXE
WSUS Client Diagnostics Tool

Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is running. . . PASS
        Wuaueng.dll version 7.6.7600.256. . . . . . . . . . . . PASS
                This version is WSUS 2.0

Checking AU Settings
        AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                Option is from Policy settings

Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use

Checking Connection to WSUS/SUS Server
                WUServer = http://wsus.mydomain.local/
                WUStatusServer = http://wsus.mydomain.local/
        UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
        Connection to server. . . . . . . . . . . . . . . . . . PASS
        SelfUpdate folder is present. . . . . . . . . . . . . . PASS

Press Enter to Complete
When I run the server version, it hangs and lgs the following event id: 1000

Faulting application name: WsusDebugTool.exe, version: 0.0.0.0, time stamp: 0x429d04ac
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17514, time stamp: 0x4ce7bafa
Exception code: 0xe0434f4d
Fault offset: 0x0000b727
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13
I just noticed I downloaded the server tool for WSUS 2.0

http://technet.microsoft.com/en-us/windowsserver/bb466192.aspx

Is there a 3.0?
Please see the c:\Windows\WindowsUpdate.log for any errors
Run the following .bat on clients to speed up the checkin process

%Windir%\system32\net.exe stop bits 
%Windir%\system32\net.exe stop wuauserv 
%Windir%\system32\net.exe stop cryptsvc
reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v LastWaitTimeout /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v DetectionStartTime /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v NextDetectionTime /f
del %WINDIR%\WindowsUpdate.log /S /Q 
rd /s /q %windir%\softwareDistribution
%Windir%\system32\net.exe start cryptsvc
%Windir%\system32\net.exe start bits 
%Windir%\system32\net.exe start wuauserv 


sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)


sc sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)

wuauclt /resetauthorization /detectnow
wuauclt /reportnow

exit /B 0 

Open in new window

I had a look in c:\Windows\WindowsUpdate.log and there are lots of references to the old WSUS server, which died last week.


Here is the last hours c:\Windows\WindowsUpdate.log

I've renamed the current WSUS server NEWWSUS.mydomain.local and the old WSUS OLDWSUS.road3.local
dstewartjr, the batch file run, but didnt fix the issue.

Hopefully the log post above will help shed some light.
2012-11-07      18:03:00:949     788    6fc     Agent     * WSUS server: http://OLDWSUS.mydomain.local/
2012-11-07      18:03:00:949     788    6fc     Agent     * WSUS status server: http://OLDWSUS.mydomain.local/

Your latest entries still point to the old server

Cannot open database "SUSDB" requested by the login.

indicates that you have some misconfiguration

Error 0x80072EE2

Is your WSUS configured to run on port 8530??

also with your GPO, it is usually better to use "http://NEWWSUS" rather than "NEWWSUS.mydomain.local"
Where do I set it so it uses the new server.  I copied the old group policy, so it should have replaced all the settings with the new ones.


Any idea what the Error 0x80072EE2 could be?


WSUS is running on 8530 (that's what it picked)
Where do I set it so it uses the new server.  I copied the old group policy, so it should have replaced all the settings with the new ones.

Under "Specify intranet Microsoft update service location"
http://technet.microsoft.com/en-us/library/cc720533%28v=ws.10%29.aspx

Any idea what the Error 0x80072EE2 could be?

Yes, because you dont have ":8530" specified "http://NEWWSUS:8530"
Just realised, that log export was from the new WSUS server.  So it was receiving the old GPO.  I've updated it so it's pointing at itself.

Now I realise that the log exists on the clients.

Here is the Windows 7 client log
ASKER CERTIFIED SOLUTION
Avatar of Don
Don
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Excellent thanks!