Link to home
Create AccountLog in
Avatar of Gerhardpet
GerhardpetFlag for Canada

asked on

SBS 2010 Exchange 2010 not receiving all emails

I have a customer who has a SBS 2011 Exchange 2010 which I don't know very well. I'm not a OS and Exchange person and their IT source is not helpful at all.

I'm setting up Magento for them and have a contact form sent to an email to the exchange. The email never gets to the exchange and also they have a few customers telling them that their emails never get to the exchange server

When we change the email on the contact form to a gmail address or other outside email then it works.

Also now my customer has it setup so that the email from the Magento contact forma goes to gmail and then forward to the exchange and then it works.

Any ideas what to look for?
Avatar of golfinfo
golfinfo

Hi,
In first i think you must track the email in the exchange console to know why i didn't receipt in mailbox.

Second could you send a form example here.
Check if content filtering is enabled on it, i know it comes enabled by default with SBS. So either diable it or change the values so emails can flow in properly.
You will have to check the Anti Spam tab under organization configuration, Hub transport to find answers.Check which option is enabled, either disable it or change the values.
Avatar of davorin
First I would check SMTP receive logs:
http://technet.microsoft.com/en-us/library/bb124531.aspx
Here you have procedure how to enable SMTP logging on receive connectors and set the location of SMTP logs (if not already enabled).
If you see that the email is not rejected on SMTP connector, then you can check Agent logs, which will tell you if some of antispam agents have rejected the mail. The location of logs is C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\AgentLog.
Avatar of Gerhardpet

ASKER

My customer thinks it may be the way the mx records are configured. I will wait for him to give me a status update
ASKER CERTIFIED SOLUTION
Avatar of Gerhardpet
Gerhardpet
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I found the solution to this problem