Link to home
Start Free TrialLog in
Avatar of pyotrek
pyotrek

asked on

Out of office assistant stops working from different subnet

I have simple network with 1 Exchange 2010 server and LAN with class C address scheme.

I had to extend the sub-net, as I was running out of IP addresses for devices etc.

My current setup is as follows:

sub-net: 192.168.0.0
Mask:    255.255.254.0
Gtwy:    192.168.0.250

DHCP assigns addresses from 192.168.1.1 to 192.168.1.200

all servers and devices reside in 192.168.0.0 subnet.


After the change I have noticed that some of the functionality of my network stopped working.

1. Out of office assistant in Outlook will not work from workstations in 192.168.1.0 sub net
it gives message:

Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.

When I try to connect to Out of office assistant on the workstation in sub net 192.168.0.0 everything works as it supposed to.

2. I am also unable to connect to the websites that are hosted on our internal server - for example if I try to connect to www.ourdomain.com from sub net 192.168.0.0 it works, but it does not from 192.168.1.0

I suspect it has something to do with our gateway that is on 192.168.0.250 with sub net of 255.255.255.0 - I have no option to change it to 255.255.254.0

The only thing that I can do is to allow for multiple subnets - so I added subnet 192.168.0.0/255.255.255.0 and 192.168.1.0/255.255.255.0

any idea what is wrong with this picture?
ASKER CERTIFIED SOLUTION
Avatar of Neil Russell
Neil Russell
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of pyotrek
pyotrek

ASKER

OK I was under impression that adding 2 sub nets on the gateway would fix the issue, as you see on my previous post my gateway allows me to setup LAN IP as:

192.168.0.250/255.255.255.0
, but it allows me to add multiple sub nets as follows:

192.168.0.0/255.255.255.0 and 192.168.1.0/255.255.255.0 - I guess it is not enough.

I can see that having effect on accessing www.ourdomain.com from the sub net 192.168.1.0

but why the Out of Office assistant is not working?

I should mention that I have no issues with the workstations on subnet 192.168.1.0 to connect to Exchange (or other servers, devices and shares) on sub net 192.168.0.0 with the exception of Out of Office assistant?
It will have an effect on ALL Networking between the 192.168.0.0 subnet and the 192.168.1.0 subnet
Avatar of pyotrek

ASKER

But it does not have effect on ALL of the Networking.

All my servers and printers, and gateway are on 192.168.0.0 and all of the workstations are on 192.168.1.0.

I can communicate fine between sub nets without any issues - as far as file sharing printing connecting on different ports telnet etc.
In simple terms your network is misconfigured. Simple as that.

If you want your network to function correctly you need to EITHER change the mask on the gateway or have two seperate subnets with a 255.255.255.0 mask AND a router.
Avatar of pyotrek

ASKER

Netlsr was right that I need gateway that will route 2 sub nets - and my gateway is capable of routing multiple sub nets if it only worked. Turned out that the settings were correct, but the hardware was not doing what it was supposed to.
Got new hardware and it works now.
Avatar of pyotrek

ASKER

Please have NETSLR read my closing comment and possibly it will explain why I awarded C.

NETSLR comments are perfectly true with exception that they did not refer to my question.

I have indicated that my hardware is setup with subnets, but it does not work - and I got answer the the gateway has to be setup to route between sunbnets. Seems like NETSLR may have not noticed my 3 separate comments that I have hardware just like that.
In effect it was not resolving my issue - the comment were in general correct, but not applicable for this particular issue which was faulty hardware not wrong setup.