Link to home
Create AccountLog in
Avatar of syssolut
syssolutFlag for United States of America

asked on

How do I create a hardware raid with Win 7 Ultimate

I have a Lenove thinkserver that has an LSI Raid card.   I am running two Sata Constellation 1 Gb drives.   My customer wants Windows 7 Ultimate on the server.  When I go into Windows 7 and start the  installation, it asks me to "Load drivers"  I load the LSI driver then I can see the 2 drives.  But where and how do i create the RAID 1.   I watched during bootup and cannot find where that is asked.   It is not in the BIOS.  Is it in 7 somewhere?
SOLUTION
Avatar of Stelian Stan
Stelian Stan
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
You can do it through the BIOS on the controller.   I can't remember the key sequence but just watch the POST and press whatever it tells you.

The RAID needs to be set up BEFORE installing the O/S, as the total usable blocks decreases because the RAID mode on the controller chews up a few MB worth of disk space starting at physical block 0 on each disk.
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of syssolut

ASKER

I set up the Raid in Bios uder SATA configuration.   The drives are not showing because the Raid in the BIOS is for the RAID on the motherboard itself.   As I go through the bootup it comes to a page that shows
PCI Slot  ID  LUN  Vendor    Product                                          Revision                 Capacity      -------------  ----   ------   ----------    --------------                                        -------------                  -------------
17                          LSI         LSI MegaRAID SAS  9240-8i           2.120.254-150        0MB
17         16      0     ATA        St1000NM0011                             SN02                        953869MB
17         17      0     ATA        ST1000NM0011                            SN02                        953869MB


2   JBOD(s)  found on Host Adapter
2  JBOS(s) Handled by BIOS

0 Virtual Drive(s) found on the host computer

0 Virtual Drive(s) handled by BIOS
Press ,Ctrl><H> for WebBIOS or press <Ctrl><Y> for Preboot CLI

MegaPCLI SAS Raid Management Tool
Copyright(c) LSI Corporation, 2008
Use -h -a<n> for controller specific help, where n is the controller index
use -v -a<n> for controller specific version, where n is the controller index
Use q to exit from $ prompt

  Then it goes to:

LSI MegaRAID Software RAID BIOS Version A.10.10211615R
LSI SATA RAID Found at PCI Bus No:00 Dev No:1F

Then it says Device Present at port 5     HL-DVD-STDVD-RAM GH82N
No Virtual  drive(s) Configured
No hard Disks found.   LSI Software RAID can not be configured


I do not see the usual place to hit CTRL M to set up RAID

It is a Lenovo TS430.    Any ideas?
THis server has apparent RAID on he motherboard plus athe LSI RAID card which is connected to the board that the Sata Drives connect to.
The LSI controller Raid can be configured before loading the O/S or within the O/S.  I recommend the former. Make sure any fast boot options are disabled in the BIOS.  Then if the motherboard/BIOS  supports the controller, during the boot sequence there should be a brief post about configuring the LSI and press ctrl+C to access the configuration utility.

To do it within the O/S, you need to add the drivers at boot, (may need to use server 2008 R2 drivers) and then when the O/S is loaded there should be LSI software you can install to configure RAID.
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I had to also hit Ctrl H to get into Web Bios
Thank you much.    : )


>> ...also hit Ctrl H...

Interesting. Thanks for the info.    : )