Link to home
Start Free TrialLog in
Avatar of tsnirone
tsnirone

asked on

Mac Mini" OS X Server 6 Extremely slow "all of a sudden"

After one of my clients tried to transfer some licence information/usage from the server to a memory-key/hard-lock so that one of the users could use their program off-site their server is now extremely slow. This process involved following this:

http://www.archicadwiki.com/RemoteKeyUpgrade

The server is now almost impossible to use, even opening up Terminal takes 2-3 minutes.

I've done several restarts, checked that there is sufficient hd-space and enough memory free. Also there are no programs hogging the cpu. System update found no updates. No antivirus-program installed.

I did try to open Server Admin and tried to look for some log-info, but got error-msg saying "Could not connect to <name>.local" (where <name> is the servername)

Any ideas on how to figure out this problem?
Avatar of strung
strung
Flag of Canada image

Try running Verify Disk from Disk Utility. Also repair permissions.
Avatar of tsnirone
tsnirone

ASKER

Thanks strung, could you (or anyone) please post a step-by-step-guide on how to do this?
Unless your server has a RAID disk, just open Disk Utility found in the Applications/Utilities folder.
Just wanted to pop in to say that this is taking "a while". I was a bit delayed and in addition the tests are still running. I'll be back with more details. Thanks for your help so far! :)
After running “Repair Disk Persmission” for almost 3 whole days there was a couple of hundred of these:
 
Permissions differ on «usr/share/xxxxx/xxxxx/xxxxx», should be drwxr-xr-x, they are drwxrwxr-x.

I now have started “Verify Disk” (since "Repair Disk" was greyed out) – there is no indication yet on how long this will take.
The client restarted the server without me being able to verify the "Verify Disk"-process. So I'm not sure if has finished or not.

Now the client dont want to use any more time on this server and want to change it to a new Windows based server instead.
I restarted the "Verify Disk" process and it gave the following error:

Verifying volume "HD"
Verifying volume when it is mounted with write access.
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Incorrect block count for file system.log
(It should be 131 instead of 132)
Invalid node structure
The volume HD was found corrupt and needs to be repaired.
Error: This disk needs to be repaired. Start up your computer with another disk (such as you Mac OS X installation disc), and then use Disk Utility to repair this disk.

Open in new window


"Repair Disk" is still greyed out.

This is a Mac Mini though and it has no CD-rom.....how to proceed??
If it is Lion or Mountain Lion Server, it should have a recovery partition:


http://www.dummies.com/how-to/content/mountain-lions-recovery-hd-partition.html

Boot from the recovery partition, then run repair disk from disk utilities.
They have Snow Leopard OS X 10.6, which does not seem to react to Command+R, what to do??
You can try booting in safe mode (by holding down the shift key) which will run an automatic disk repair. The run Verify Disk again to see if the disk has been repaired.

If not, then start up in single user mode and run fsck -fy as described by Apple here:

http://support.apple.com/kb/TS1417
I started the server using Shift (safe mode). This did not help the extreme slowness on the server.

I then started in single-user terminal mode and ran "/sbin/fsck -fy" and it did alterations on the disk. I reran the command several times (as suggested) and it reported the disk as OK. The server however is not any faster.

FontBook did not reveal any problems and I am unable to find any background processes hogging the server.


"tail -f /var/log/system.log" gives:

edu.mit.Kerberos.krb5kdc[1409]: krb5kdc: failed to initialize sandbox: profile not found
com.apple.launchd[1] (edu.mit.Kerberos.krb5kdc[1409]): Exited with exit code: 1
com.apple.launchd[1] (edu.mit.Kerberos.krb5kdc): Throttling respawn: Will start in 10 seconds
com.apple.launchd[1] (com.apple.distnoted[1410]): posix_spawn("usr/sbin/distnoted", ...): No such file or directory
com.apple.launchd[1] (com.apple.distnoted[1410]): Exited with exit code: 1
com.apple.launchd[1] (com.apple.distnoted): Throttling respawn: Will start in 10 seconds
com.apple.serialnumberd[1424]: sandbox-exec: No such file or directory
com.apple.launchd[1] (com.apple.serialnumberd[1424]): Exited with exit code: 65
com.apple.launchd[1] (com.apple.serialnumberd): Throttling respawn: Will start in 10 seconds

Open in new window


over and over and over (not sure what line of the ones above that is the "first line" - also; I typed off the above code so there might be some typos)

The numbers above (ie "1409", "1410" and "1424") changes....

Heeeelp!!?? :D
Have a look at this link re the throttling respawn error message:

http://reviews.cnet.com/8301-13727_7-20068791-263.html
ASKER CERTIFIED SOLUTION
Avatar of strung
strung
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thank you for your input! I will check this out next time I am visiting this client. :)
The client decided to retire the server so there is no need for me to fix this any longer. As a result of this I do not know if your latest suggestions would have helped. I still award you the points though since you hang in there and gave very good suggestions all the way.