Link to home
Create AccountLog in
Avatar of Wolf
WolfFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Virtual Machine unable to access IBM Blade host CD in Media Tray

Hello

I am trying to give one of my virtual machines access to its host media tray, that contains a CD.

We have 10 IBM blade servers and 1 media tray.  I have assigned the media tray to the blade that hosts the virtual machine.

I've then tried to point the virtual machines cd drive to the host device but in vsphere it says that not host is available.

We are running ESXi 5.0

Any ideas how i get it to display?  I can point it to my laptops cd drive fine, just not the vm's host

Thanks in advance

Andrew
ScreenHunter-24-Nov.-09-09.44.jpg
ASKER CERTIFIED SOLUTION
Avatar of Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Andrew Hancock (VMware vExpert PRO / EE Fellow/British Beekeeper)
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of Wolf

ASKER

Yes, i know, however, we don't actually have the media yet.

An external engineer is coming to site over the weekend and doesn't have any experience with vmware.

I need to be able to have the vm ready so that he can just put the cd in the media tray and it will appear on the vm
If you have a KVM cable attached to the Chassis Management Module, remove it, and then try your media operation again.

(The only time I've seen the behavior you describe is when a KVM is plugged into the USB/VGA ports on the CMM.)
Avatar of Wolf

ASKER

Tried removing the KVM and it still doesn't work.

The only way we've managed to get it to work is to migrate all the VM's to another host, and then reboot the host with the media tray attached.  Obviously this isn't ideal, anyone know a solution?

Thanks
it sound like the cd drive not working then
Keep the KVM off for a few days. You have to keep it out of the equation long enough to completely rule it out as the cause.

After removing the KVM, it's possible that the reboot was needed in order to "wake up" communication to the blade from the media tray.

A reboot of the CMM after removing the KVM may have allowed you to use it as well (without the need to have to migrate VMs off the blade and then reboot it.)
actually I have seen this if its already connected to a vm it needs to be released
They wouldn't have been able to migrate all VMs off that host if the drive was assigned to one of them.
Avatar of Wolf

ASKER

OK, we've left the KVM off for several days and it hasn't made any difference

It's not a problem with the Media Tray itself as you can boot from it without any problems.

The only way we can do it is:

1) Migrate all the Vm's to another host
2) Shutdown the host
3) Assign the Media tray to the host
4) Start the host up again
5) Migrate the VM's back to the host

After the above, the VM's on that rebooted host can access the media tray

However, if you then want another host to access the media tray, you have to repeat the process

Any other ideas?

Thanks