Link to home
Start Free TrialLog in
Avatar of asetia
asetia

asked on

Unable to connect to devices when connect wirelessly to Sky router connected through BT Openreach modem

I recently upgraded to Sky Fibre Optic broadband. I am now unable to connect to other connected devices when I connect my laptop, iPad etc. wirelessly to the router. However, I am able to connect if I connect wirelessly to another router which is connected to the Sky router and also if I connect to the Sky router with a physical ethernet cable. I am able to connect to the internet when I connect to the Sky router wirelessly. This problem is consistent for connecting 2 network printers and my SKY+ HD box.

To give a simple example, stripping out other routers and other devices:
Set up:
BT OpenReach modem connected to Sagem F@ast2504n router
Brother MFC9840CDW printer connected with Ethernet cable to Sagem router

I am able to connect to the printer (scan print etc.) when my laptop is connected to the Sagem Router with a physical Ethernet cable.
I am NOT able to connect to the printer (not able to scan print etc.) when my laptop is connected to the Sagem Router via a wireless connection.

If someone can help me solve this problem, I expect the other connection issues will also get resolved as they appear to stem from the same issue.
Avatar of mlongoh
mlongoh
Flag of United States of America image

I'm not familiar with the Sky brand, but I can tell you that my Netgear wireless router offers two wireless SSIDs for connecting.  One is a "guest" wireless network, which provides access only to the Internet.  The other is the "main" wireless network which gives me access to the local network as well as the internet.  I believe that this is standard for most modern routers and wonder if you are connecting to what the router considers the "guest" wireless network, and thus only can access the Internet.
Avatar of asetia
asetia

ASKER

Thanks for the suggestion. I haven't come across this before. In my case, I don't think this is what is happening as I don't see another SSID and also, in the router settings pages at http://192.168.0.1 again there is only one SSID.
ASKER CERTIFIED SOLUTION
Avatar of mlongoh
mlongoh
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of asetia

ASKER

Wireless Access Point: enabled
WPS: enabled
Wireless Isolation: not enabled
Security options: WPA/WPA2-PSK (Mixed Mode)
WPA Encryption: TKIP+AES
Wireless isolation is what I'd play with first.  That setting, if enabled, does just what you're experiencing... only allows access to the Internet and not to the rest of the network.  Change it to enabled.  Test. And then change it back and test.
Avatar of asetia

ASKER

I tried your suggestion. Had to use direct ethernet connection after setting Wireless Isolation. Didn't work wirelessly after changing the setting and also after changing it back.

N.B. I didn't mention it earlier but, if I search for a a printer, both my network printers come up even when I'm connected wirelessly to the router. This was also the case before.

Any more ideas/suggestions?
Yes.  Look at the routing and firewall settings.
Avatar of asetia

ASKER

Managed to get the printers working by disabling WPS.

Some of the devices are still a bit problematic e.g. can connect to Sky+ HD box through the Sky router from one iPad but only through another wireless router (connected by ethernet cable through the Sky router) for another iPad (older iPad).

Thanks for all the help.

FYI, There don't appear to be Firewall settings (Sky also said this when I spoke to them about this problem) which seems very strange. Might be because the Router mode (set on Auto) is picking up WANoE mode as opposed to ADSL. Don't know, I don't want to change these settings as finally got the printers working.

Thanks again.
Well that doesn't make sense.  WPS is Wi-Fi Protected Setup.  It's supposed to allow for the configuration of wireless devices via synchronized button presses on the router and the wireless device.

Regardless.  Thanks for the points.
Avatar of asetia

ASKER

I agree, it doesn't make sense but it has made a difference.
Avatar of asetia

ASKER

For some reason this issue seemed to go away temporarily (a day) but wasn't actually resolved. Any more thoughts would be greatly appreciated.