Link to home
Start Free TrialLog in
Avatar of csg-unit
csg-unitFlag for United States of America

asked on

Cisco C881 Router DHCP issue

Hello all,

I have a C881 router configured as an MGCP gateway.  I am going to have 4 phone connected to the four switch ports on the back of the router.  I have 3 VLANs configured (Management, Data, and Voice).  I have a DHCP scope for both Data and Voice using the IP of each vlan interface as the default router for that scope.  For some reason, my phones are not getting the correct DHCP.  They are getting IP addresses in the Data network, not the voice network.

Below is the config.  Any help would be appreciated!


=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.11.09 01:01:24 =~=~=~=~=~=~=~=~=~=~=~=
sh run
Building configuration...


Current configuration : 11685 bytes
!
! Last configuration change at 05:49:37 UTC Fri Nov 9 2012 by synergy
! NVRAM config last updated at 05:55:13 UTC Fri Nov 9 2012 by synergy
! NVRAM config last updated at 05:55:13 UTC Fri Nov 9 2012 by synergy
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
network-clock-participate wic 0
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2587525293
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2587525293
 revocation-check none
 rsakeypair TP-self-signed-2587525293
!
!

ip source-route
!
!
!
ip dhcp excluded-address 192.168.112.1 192.168.112.9
ip dhcp excluded-address 192.168.2.1 192.168.2.9
!
ip dhcp pool PHONES
 network 192.168.112.0 255.255.255.0
 default-router 192.168.112.1
 option 150 ip 192.168.10.110
 dns-server 192.168.0.2 192.168.0.10
!
ip dhcp pool PCs
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
 dns-server 192.168.0.2 192.168.0.10
 option 150 ip 192.168.10.110
!
!
ip cef
ip domain name XX.local
ip host XXXX 192.168.110.10
ip name-server 192.168.0.10
ip name-server 192.168.0.2
ip multicast-routing
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
!
license udi pid C881-V-K9 sn FTX1631856U
!
!
!
!
!
!
class-map match-any AutoQoS-VoIP-Remark
 match ip dscp ef
 match ip dscp cs3
 match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
 match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
 match protocol rtp audio
 match access-group name AutoQoS-VoIP-RTCP
!
!
policy-map AutoQoS-Policy-UnTrust
 class AutoQoS-VoIP-RTP-UnTrust
  priority percent 70
  set dscp ef
 class AutoQoS-VoIP-Control-UnTrust
  bandwidth percent 5
  set dscp af31
 class AutoQoS-VoIP-Remark
  set dscp default
 class class-default
  fair-queue
!
!
!
interface BRI1
 no ip address
!
interface BRI2
 no ip address
!
interface FastEthernet0
 description PC / Phone Port
 switchport access vlan 102
 switchport voice vlan 122
 no ip address
 auto qos voip
 auto discovery qos
 spanning-tree portfast
 service-policy output AutoQoS-Policy-UnTrust
!
interface FastEthernet1
 description PC / Phone Port
 switchport access vlan 102
 switchport voice vlan 122
 no ip address
 auto qos voip
 auto discovery qos
 spanning-tree portfast
 service-policy output AutoQoS-Policy-UnTrust
!
interface FastEthernet2
 description PC / Phone Port
 switchport access vlan 102
 switchport voice vlan 122
 no ip address
 auto qos voip
 auto discovery qos
 spanning-tree portfast
 service-policy output AutoQoS-Policy-UnTrust
!
interface FastEthernet3
  description PC / Phone Port
 switchport access vlan 102
 switchport voice vlan 122
 no ip address
 auto qos voip
 auto discovery qos
 spanning-tree portfast
 service-policy output AutoQoS-Policy-UnTrust
!
interface FastEthernet4
 description WAN
 ip address x.x.x.x 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 crypto map VPNtoSS
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 no ip address
 ip tcp adjust-mss 1452
 shutdown
!
!
interface Vlan12
 description Management VLAN
 ip address x.x.x.x 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan102
 description Data VLAN
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan122
 ip address 192.168.112.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source route-map nonat interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
ip access-list extended AutoQoS-VoIP-Control
 permit tcp any any eq 1720
 permit tcp any any range 11000 11999
 permit udp any any eq 2427
 permit tcp any any eq 2428
 permit tcp any any range 2000 2002
 permit udp any any eq 1719
 permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
 permit udp any any range 16384 32767
!
ip sla 1
 icmp-echo x.x.x.x source-ip x.x.x.x
 frequency 240
ip sla schedule 1 life forever start-time now
!
!
!
route-map nonat permit 10
 match ip address 101
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.162.12900705 30 absolute rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
voice-port 5
!
voice-port 6
!
voice-port 7
!
ccm-manager fallback-mgcp
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server x.x.x.x
ccm-manager config
!
mgcp
mgcp call-agent MBCUCM service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface Vlan122
mgcp bind media source-interface Vlan122
!
mgcp profile default
!
!
!
banner login ^CCC
/----------------------------------------------------------------\
|                            WARNING                             |
|    UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED    |
|----------------------------------------------------------------|
|                                                                |
| You have accessed a restricted device. The actual or attempted |
| unauthorized access, use or modifications of this system is    |
| strictly prohibited. Unauthorized users are subject to         |
| disciplinary proceedings and / or criminal and civil penalties |
| under state, federal, or other applicable domestic and foreign |
| laws. The use of this system may be monitored and recorded for |
| administrative and security reasons. Anyone accessing this     |
| system evidences an express consent to such monitoring and     |
| agreement that if such monitoring reveals evidence of possible |
| abuse or criminal activity, system personnel may provide the   |
| results of such monitoring to appropriate officials.           |
|                                                                |
\----------------------------------------------------------------/^C
!
line con 0
 logging synchronous
 login local
line aux 0
line vty 0 4
 login local
 length 0
 transport input telnet ssh
!
ntp source FastEthernet0
ntp server 192.43.244.18
ntp server 128.59.59.177
ntp server 128.173.14.108
ntp server 132.236.56.250 prefer
end

MB-CF-RT881#
ASKER CERTIFIED SOLUTION
Avatar of asavener
asavener
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of csg-unit

ASKER

CDP wasn't enabled.  Thanks for the help.  Can't believe I missed that.