Link to home
Create AccountLog in
Avatar of bizco
bizcoFlag for United States of America

asked on

Windows Server Backup Failing on SBS 2011 Standard

For the past month or so, we have had a Windows Server Backup fail on an SBS 2011 Standard server off an on. At first I thought it was just a VSS issue as we were getting the VSS event 1376 errors (Volume Shadow Copy Service error: Failed resolving account account_name with status 1376. Check connection to domain controller and VssAccessControl registry key) I have resolved that by following the KB article from Microsoft. When looking at the errors in WSB it shows: System State: The operation was stopped. Detailed error: Access is Denied.

However, the backups continue to fail. I moved the backup time from 11PM down to 9PM, and then to 8PM thinking something on the server may be running that's causing the failure. It worked the first night, then continues to fail.

If I run the backup during the day anytime it works.  The other errors in the event viewer that I can find are:

Event 517: The backup operation that started at '¿2012¿-¿11¿-¿09T02:00:28.173217300Z' has failed with following error code '2155347997' (The operation ended before completion.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

and

Event 2007: Information Store (2228) Shadow copy instance 42 aborted.

and

Exchange VSS Writer (instance 302132b8-91c9-4803-aed0-0e1d21eb2b3c:42) has completed the backup of database 'Mailbox Database' with errors. The backup did not complete successfully, and no log files were truncated for this database.

Any help is greatly appreciated!
Avatar of PaulD77
PaulD77
Flag of United States of America image

Well, The VSS issue with exchange is a common one on backup of SBS 11.  did you run a vssadmin /list writers from the cmd prompt to verify that the exchange VSS writer is in failure state?  How long are your backups running for?  If the are running for a long time, There is an issue where VSS Exchange backups fail after X hours based on the maximum lifetime setting for a ticket...you may want to take a look at the setting mentioned here:

Default is set to 10 hours. To change the default
 edit the default domain policy: Computer Configuration -> Windows Settings -> Security Settings -> Account Policies -> Kerberos Policy. Change the Maximum lifetime for service ticket and Maximum lifetime for user ticket. Note that these Kerberos policy changes only get applied to the domain root so if you create a new policy and put it in an OU other than the root of the domain the settings will not take.

Also, are you just using the windows backup?  I would highly reccomend getting a 3rd party backup like Symantec BU exec.  I found that putting the exchange as a seperate backup from the rest of the server also helped.
Avatar of bizco

ASKER

PaulD77--The backup fails after 2 minutes usually. None of the VSS Writers are reporting a failure state. I agree, we should be using something other than Windows Backup.

nbhaskar--I tried what was suggested in the MS Blog and had a few ImagePaths that were incorrect. I changed those, and re-ran the backup. It completed successfully. Since this was the case in the past (and it always worked when running manually) I will make sure it continues to complete on schedule and report back.

Thank you both so much for your assistance!
Avatar of bizco

ASKER

Ok, so the manual backup I did worked. The scheduled backup for 8PM failed again with the same Access is Denied error on system state. Any other ideas?
when you run a vssadmin list writers...does a "System Writer" come up in a stable state?
Avatar of bizco

ASKER

Yes, all writers are in the stable state when running 'vssadmin list writers'

Thanks,
Kyle
Is the server completely up to date?  Theres a hotfix for a related issue but if you are up to date it's already installed.  Does the Source disk have 10% or more space for it to create shadow copies?  Have you checked the shadow copies config on the disks being backed up- schedule, limits, etc. These are a few issues that could cause this error...lastly, you may need to follow these directions in changing permissions on windir fiiles

http://support.microsoft.com/kb/2009272
ASKER CERTIFIED SOLUTION
Avatar of bizco
bizco
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I have been trying to resolve our SBS 2011 backup problems and I resolved following: http://support.microsoft.com/kb/2009272 

Hope it helps someone...
Avatar of bizco

ASKER

migrated to a different backup software