Link to home
Start Free TrialLog in
Avatar of Karolynn
KarolynnFlag for Canada

asked on

$KeepPrivate field appears set to 1 after a replication

Hello,

ok, our server crashed completely not able to recover and get backup. I had a databases replica on another server so replicated them back to the original server. Now, since this event, nobody is able to forward, copy any emails from those databases because a $KeepPrivate field appeared in every documents of every databases. The users acl is ok on each DB, they have the Replicate or copy documents on the ACL.
As Admin, I have created an agent to remove that KeepPrivate field from all documents... the agent is running properly and I see the field is removed and I can forward the message... but nobody else can... it seems to remove it just for me.
I took the ID of a user and ran the agent under his name... filed disparreared. Then when he logged back to Notes on his PC, same issue, the field was back!... what is the relation with the client installation? How can it be removed for all users?

Please help!

Thanks!
Avatar of Sjef Bosman
Sjef Bosman
Flag of France image

That's a strange story... Did this happen for all databases that got lost or damaged beyond repair? Are you talking about only one database, or multiple database??

Could it be that the replica databases you created was on a server that lacked the option "Replicate or copy documents" in the ACL, with only Author access?

More info here
Avatar of Karolynn

ASKER

Thank you for your input.
It is for all databases.
The server from which I have replicated the DBs had manager access with replicate & copy through the local domain servers group in the ACL of all DBs.
My concern is to remove that $Keepprivate field for all users.. I have about 250 users consulting and trying to forward mail from those DBs.

I have tried a few agents... to delete the field, to modify it and nothing is working... it does remove it but just for me...
What kind of databases?  What is the template? Do you have the template?
here is the template... NSF dbs.. when an email is sent or received to/from a particular internet domain, a copy is done and deposited in those DBs... the router that puts them and copy them doesn't alter them at all.... there is something weird and it's really just since those were replicated...

I have renamed with extension txt since you don't accept NTF
CERMail-in.txt
forgot to mention... I have added almost all agents we tried in...
Were you able to find out exactly WHEN the KeepPrivate field was created? Maybe the field is already present in documents stored in the database on the other server?

It could also be that a database has gone corrupt, which could also affect the design. Did you already try to use Replace Design to update a database?

By the way, what Notes and Domino releases do you use?
Well as soon as we have put them back on after the replication from the other server. I am sure the field was not there on the toronto server since users were able to use those replicas while we mounted back the server that crashed. Now, since the replication, they have the same issue on all replicas.

Our servers are running Domino 8.0.1
Notes clients are notes 8
By the way, i have tested with Notes 6.5 and the same issue occurs... The field seems to be automatically there for each user on each client.... Using the same ID on different installation.... The issue is there everytime.... The agent is just removing the field for that particular user on that particular Notes installation..... How can i get the field removed for all users on any installation?
There is no such thing as a "personal" field in Notes, which means that, if the field pops up again, it's somehow re-created. I have never seen this behaviour before. I also have some difficulty picturing how your procedure works, it's hard to imagine the exact flow, which makes it too hard to understand where things goes wrong.

What you could do: do some cleaning up of a database, verify that a document doesn't have the KeepPrivate flag, then execute some action(s) that your users would do, and check whether the flag is now present. If it is, can you tell us exactly what the user did, or what you did, or if you only replicated, or whatever it is that happened?

I could really do with some hands-on experience of your problem. Much as I'd love to fly over to Montréal, I think you'd better ask a local IBM/Lotus Business Partner to fix this for you. Désolé...

Some general remarks:
- R8.0 is very buggy, don't use it
- R8.0.1 is buggy, better not use it
- R8.0.2 is stable
- R8.0.3 is good
- R8.5 and R8.5.1 are very buggy
- R8.5.2 is ok
- R8.5.3 is very good

Meaning: an upgrade might do wonders...

Bon courage!
Going crazy here.... all $KeepPrivate fields are removed from forms... I see nothing under the admin.ID... but with my personal (even if I am in the notes admin groups and manager, and with user id too, the field is there...
I have upgraded to 8.02 fix pack 6
Field is still there for all users except me...
If I make a local copy of one of the DB (with my personal ID), the field is not there!... so there is something weird when it's on server... and with any other ID or client viewing the document and trying to forward...

I have tried to run the agent on behalf of the server, admin etc.... no change
Agent logs always give the right number of ducument that are modified (but not really as the field is stuck there even if removed from form)
IBM is not helping :-(

Just hoping someone here will have an idea...
> If I make a local copy of one of the DB (with my personal ID), the field is not there!
That's unlikely, no, improbable, or better, virtually impossible...

How do you determine that "a field is there"?
Sounds like something is going on in the ACL.  I can see that a number forms are setup so that every time a document is mailed, the keepprivate field is set.
some of the places where $KeepPrivate is set on mail:
Subform:
$LotusFaxMemoSubform
Forms:
ToDo
Personal Stationary
(wForward)|wForward
Document Memo|$DocMemo

Would investigate further but a cold turned into a maxillary sinusitis means that a killer headache hinders me completing it.
So sorry to hear about your cold! Take care of yourself! I really appreciate your help!!!

I see the field in each document properties of each documents in the DBs that are on server.
I have remove the field or comand to put the field in some of the forms you named but not all... I'll check them again.

What is weird is that we never had an issue before the server crashed and replicated the DBs from the Toronto server... so is it those forms/template or the new mounted VM server that cause this... anyway why can't I remove the field for all users... even if I don't click to foward and just check properties, the field is there under other user IDs (so that would remove the addition when mailed no)?

I've tested again with another DB.... on that new mounted VM server, I open one of the DBs, I checked some documents under my name and I see the field there.... I go and make a local copy of the same DB on my laptop, reopen that same DB, same documents and no more $KeepPrivate field!
See the printscreens... so I can forward from the local copy only

So weird.... could it be a general security on that VM server?

Thank you so much!!!! and drink a lot of liquid!!
Form-the-server.jpg
From-local-copy.jpg
My mailfile is on another server... I have created a copy of it on that "problematic server"... it was ok, then, I created a another one in the particular folder where all the DBs are and all documents became with the KeppPrivate field..... so it's a setting that seems to touch that folder!!!

I have created a new folder, created some test dbs copies, they seems ok.... stop the server and renamed the folder to the right name (which is CER).... strat the server, went to check the dbs copies that were ok, and bang the filed appears....

Something is altering any folder called CER
But that is completely new... I am lost!
Directory ACL was not enabled (never used it) I have enabled it but I see you can just select users and no security etc... so...?!?!

I have no idea... why my personal mailfile gets that field that was never there when i make a copy in that folder....
I was thinking it's because the folder was originaly replicated for the Toronto server since the problem began at that replication but even if I crete a new one with the same name I get the problem....
Is this your only application database, or are there others? There could be scheduled agents in other databases that cause this behaviour.

Who was the last updater of  the document, and could that have been an agent? For example, if the name of that person pops up in every newly modified document or so.
ASKER CERTIFIED SOLUTION
Avatar of Karolynn
Karolynn
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I've requested that this question be closed as follows:

Accepted answer: 0 points for Karolynn's comment #a38655521

for the following reason:

a third party tool was marking the doc... since it was not always running, that is why we saw the field appareaing and disappering<br />also, depending on the version of db, the field was named differently
Please provide the name of the tool so this knowledge does not disappear!