Link to home
Start Free TrialLog in
Avatar of jhyiesla
jhyieslaFlag for United States of America

asked on

Continuing Time Machine Issue

I have an iMac at home that was backing up to a LaCie 1 TB disk. There was a single partition that was shared by the TM backup and other files.  I am replacing this with another laCie d2 quadra drive that is 2 TB in size and I have partitioned it with 1.4 TB as regular storage and 600 GB as Time machine Storage. The partitions are correctly configured. I started backing up and all went fine for a few days. Then I started getting errors that the TM back up could not complete and if I attempted to log out or restart the Mac the LaCie drive would keep that from happening until I shut it down.  Then it would work OK for a few days and then repeat the issue. I have completely wiped and repartitioned this disk a number of times with the same result.  Here is an example of some of the errors that I am getting:
 
10/28/12 11:53:31.736 AM com.apple.backupd: Backing up to: /Volumes/TimeMachine/Backups.backupdb
10/28/12 11:53:31.833 AM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/TimeMachine/Backups.backupdb/Jon Yiesla’s Home iMac size:37
10/28/12 11:53:31.835 AM com.apple.backupd: Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/TimeMachine/Backups.backupdb/Jon Yiesla’s Home iMac size:37
 
I followed the steps in http://pondini.org/TM/A4.html and that seemed to fix it as it worked fine for several days. I had no TM errors and no issues with the disk misbehaving. Then today it messed up again.  I decided to try ejecting the two partitions and got an error on each one that they could not be ejected because something had them in use. But TM had failed and there's nothing that I know of that routinely accesses these volumes.

I have also tried many of the other steps from Pondini. All seem to help for a day or two and then fail.  Does anyone have anything else I could try or could you recommend a good TM replacement?

I was running Lion when this started and just upgraded to ML hoping that this might fix the issue, but it remains
Avatar of Eoin OSullivan
Eoin OSullivan
Flag of Ireland image

A few suggestions

1. Get a copy of TM Error Logger as it may give you better information on the errors
http://www.macupdate.com/app/mac/30349/tm-error-logger

2. Maybe it is cosmetic but I don't like to see non-standard characters in file paths .. I note your backups seem to have an issue with an apostrophe in the computer name displaying incorrectly ..
/Jon Yiesla’s Home iMac

Open in new window

Perhaps you should rename the computer in the System Preferences under Networking to eliminate the strange character

3. If partitioning the 2TB USB Drive I'd always set the TimeMachine partition as the FIRST partition and let the remainder of the space for the 2nd partition be your standard external storage.  When re-partitioning give the TimeMachine partition a different name (like TM Drive or TimeM or anything different from the previous partition) so as to ensure that 100% new preferences will be created.

4. When formatting the TM partition ensure it is the same as the format on the HD of your iMac.   Check the HFS type (extended, case-sensitive, journalled) as there are a few variations.
BTW .. if you want a TM replacement .. for one-off backups or system snapshots I'd recommend Carbon Copy Cloner ..
or for incremental backups or special data backups I'd recommend ChronoSync
neither have quite the same hourly snapshot/easy roll-back feature of TM but have other features which are useful.
Avatar of jhyiesla

ASKER

I did find that in the Sharing Preferences, I had an apostrophe in the string and I have removed that; although the .local name that went along with that did not have the apostrophe in it.  I looked in networking and the only name I see is the NetBIOS name and that is something that apparently was assigned automatically by OS X.  The weird thing is that the name with the apostrophe has been there for years without issue. Still the old drive was one big partition. I'll see how this goes over the weekend and if I still have problems, I'll move onto reformatting and putting the TM partition first; I had thought about that, but figured it really didn't make any difference. They are all formatted with the same OS X journaled partition format type.
Well, it did well for awhile and then failed again today:  here's the log file on it:


Starting automatic backup
Backing up to: /Volumes/TimeMachine/Backups.backupdb
Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/TimeMachine/Backups.backupdb/Jon Yieslas Home iMac size:37
Backup failed with error: 2
Starting automatic backup
Backing up to: /Volumes/TimeMachine/Backups.backupdb
Error: (22) setxattr for key:com.apple.backupd.HostUUID path:/Volumes/TimeMachine/Backups.backupdb/Jon Yieslas Home iMac size:37
Backup failed with error: 2

Notice that now the weird character is gone, but basically the same error.  Guess my next step is to repartition the LaCie and  this time put the TM partition up front.  Won't get to that tonight.
jhyiesla - there is a possibility that there are damaged sectors or files on the HD that are affecting the backups rather than any issue with the external drives.

Running a repair with Disk Utility when booted from an external device or drive or even better if you have a copy of Disk Warrior (http://www.alsoft.com/diskwarrior/) and a bootable USB or drive or DVD then I'd recommend using it.

Disk Warrior is a great tool for checking and repairing File System errors on OSX and any decent OSX service specialist will have a copy in their toolbox.  It has salvaged and repaired numerous macs for me over the years..
Before I put anything else out there, after I repartition everything, I'll run Disk Utility. I do not have DW.
Try the Verify Disk function in Disk Utility on your HD ... and see if it raises any issues.  If so .. then you'll have to boot from external drive or dvd and run a full repair.
Seems to me that I've done that before and it's checked out, but I'll do it again.
Like I said .. Disk Utility is OK but not the best for diagnosing and repairing HD indexing issues  .. it is adequate but I'd never trust 100% a clean bill of health from DU.

If the TM backups still fail after you've repartitioned the drive I'd put all my focus on the HD of your Mac as the only remaining cause will be related to the HD.  It'd be worth investing in DiskWarrior at that stage.
Not that I disagree with the assessment, but two things don't seem to make sense.  1. Before going to the new LaCie drive, I had absolutely NO trouble with TM. 2. If the Mac's HD is the issue, why can I get perhaps a day or two of good backups, including a full one without issue and then when it fails, it keeps failing?
On item 1  .. I've not given up on the LaCie Drive being at fault .. but if you've already run disk utility several times and it comes back clear, you've repartitioned and it is still failing you have to consider either another hardware issue like the cable or some hardware issue on the drive ... personally I've had mixed success with LaCie over the years and now avoid them as the premium price rarely merited the result.
I've heard that spin-down/ energy saving technology on some external HDDs can have issues with TM and other backup technologies .. see posts here
http://www.macsupportguy.com/viewtopic.php?f=50&t=31324


On item 2 .. once TM fails it can be very hard to get a full backup or incremental backup again as the subsequent backups will be trying to softlink to files which SHOULD be in the damaged or incomplete backup and they FAIL
Another small thing:
It is always worth IGNORING the TM backup volume in Spotlight.
Your Mac  Spotlight indexing SHOULD ignore TM drives but I always double check.  

To do this ... Drag the TM volume into the Privacy pane of your Spotlight pref's and reboot your Mac
Yeah, I did add that to the Spotlight preferences ages ago.  If this continues even after doing all of this, I may just get another drive from someone else. Do you have a particular manufacturer that you like? I stuck with LaCie since I'd had such good luck with it before.
I've had at least one issue with all the major drive makers over the years so I'd never swear by any brand.

Lately I've been using the Western Digital USB2 drives .. and they're working fairly reliably for me.  These are either the WD Elements or WD MyBook (don't waste the money on the Mac versions if they're more expensive, PC versions are perfect)
http://www.wdc.com/en/products/external/desktop/
OK, I have erased the LaCie disk and repartitioned it with a TM partition with a different name up front and the External storage with a different name on the backend. I have made sure that both partitions are listed in the Privacy table of Spotlight and in my AV solution as things NOT to scan either real-time or scheduled. I have run Very Disk on both reformatted partitions as well as my internal Mac disk and all report OK.  I'm now copying back the regular files for the non-TM partition and when that's done I'll repoint TM to the new disk and see what happens.
Fingers crossed
TM ran last night just fine, but it'll have to go several days before I would believe that the issue is solved.
Fingers double crossed
So far so good. I'll probably wait until Monday or Tuesday to say that the problem is fixed.
Well, no joy this morning. I came down to find the LaCie spinning, but no action from TM.  It hadn't backed up for almost 12 hours, but was stuck in starting backup according to TM buddy.  At least there weren't any errors.  Something, probably TM did have the disk tied up as I had to power it off in order to get the iMac to reboot.  I replaced the firewire 800 cable with a new cable, although the cable that it was using was the same one that the old LaCie had used without issue.

Any other thoughts?
I'd switch to another external drive.
I may have to. I found it again this morning spinning, no errors on the screen, but TM was hung since 1030 last night. I tried to eject it, but that just hung Finder and Finder wouldn't restart until I physically turned off the drive. Turned it back on and ran an TM and it completed just like it's supposed to.
ASKER CERTIFIED SOLUTION
Avatar of Eoin OSullivan
Eoin OSullivan
Flag of Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
The issue continues. I did finally try, after the new settings you suggested above, setting the power saver settings in OS X to NOT power down the disks. So far I've gone several days without issue, but Ive seem this before and I'd prefer to not have them spinning all the time.

I'm thinking about buying a new disk next week and just trying that. I can use the LaCie somewhere else so it's not wasted money.
All of the suggestions given were good and some did help me improve the situation. After doing many of the other listed suggestions, it was finally setting the preferences on the MAC to NOT turn off the hard disk that really "solved" the problem.  

However, since I would like to be able to not have the disk spinning all the time, I contacted LaCie. After having me run though a number of things, none of which made things better, they suggested that I upgrade the firmware. I was not able to do this as the firmware updater would NOT recognize the LaCie as a valid drive. The drive was sent to them and they did the upgrade and tested and returned the disk to me. I've placed it on my second Mac and so far it's doing OK, although it's only been a couple of days.  On the Mac that the LaCie was on, I've placed a My Book drive and it's been running perfectly for almost two weeks.