Link to home
Start Free TrialLog in
Avatar of Robert Ehinger
Robert EhingerFlag for United States of America

asked on

USB Ports Not Functioning Properly

I have a Windows 7 Pro desktop system that seems to work as it should with one notable exception. When I plug my Olympus X42 digital camera into it it does not recognize it. I can plug it into a different computer with the same operating system and it is immediately recognized and I can access my pictures. The USB ports in question have no problem seeing and installing my flash drives but not the camera. I have tried every USB port on the system with the same result. Any suggestions?

Thank you!

Robert
Avatar of dbrunton
dbrunton
Flag of New Zealand image

Incompatibility of some sort.  For example, I've seen USB flash drives that would work on some computers but not others.

It is possible that one of these devices is USB 2 and the other is USB 1 and the two devices can't go back to USB 1 together.  That is one scenario.  There may be others.

You could try a powered USB hub (example http://www.amazon.com/CyberPower-High-Speed-7-Port-USB-Hub/dp/B0006TIA8Y) and see if that overcomes the problem but no guarantee that it would.  (The Amazon link is just an example, you'll probably find cheaper ones elsewhere).
Have you checked for any "Unknown Device" entry in Device Manager? Also you should check there for any hidden/inactive entry under "Imaging devices" and "Universal Serial Bus controllers". Deleting some (unused) entries there can make it working.
What brand of computer is this ? Are there usb 3 ports. Have you checked the USB
setting under BIOS ?
ASKER CERTIFIED SOLUTION
Avatar of nobus
nobus
Flag of Belgium image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Robert Ehinger

ASKER

No unknown devices show up in Device Manager. The only thing unusual I see is PCI to USB entry with an error. When I open Properties the message is "Windows has stopped this device because it has reported problems." (Code 43)

I looked up that error code and tried the Microsoft Mr. FixIt routine with no success and then also tried a registry edit where I delete the UpperFilters registry value from registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}. I was also supposed to (according to the author of the solution) delete the LowerFilters value but there was none.

That did not work either.
Robert, what PC is this? or mobo?
is there a PCI to USB card installed?  if yes - what model?
remove it and install it in another PCI slot for testing

try updating the drivers with slimdrivers  https://www.slimwareutilities.com/slimdrivers.php

if you cannot get it running, it can be a bad card