Link to home
Create AccountLog in
Avatar of blossompark
blossomparkFlag for Ireland

asked on

unable to publish report in Sl Server Reporting Services.

Hi,
       I am trying to publish a report in Sql server reporting services and get  the error
"The permissions granted to user are insufficient for performing this operation "
any help appreciated
	
Avatar of blossompark
blossompark
Flag of Ireland image

ASKER

the user has administrator permissions on the machine
ASKER CERTIFIED SOLUTION
Avatar of ValentinoV
ValentinoV
Flag of Belgium image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Hi ValentinoV,
thanks for your response, will have access to the system in question later on and will update  you as to progress...thanks again
cannot get to the report manager web page, it asks me for credentials and doesnt accept my logon which is an admin account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
yes, i used run as admin,  put in the urlhttp://localhost/reports  and then i am presented with a Windows Security dialog box asking for User name/password , when i enter my username password, i get  the following message returned


SQL Server Reporting Services
Error      
  User 'thinkpad\Rory' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.
I have followed all the steps at the link below successfully
http://stackoverflow.com/questions/4652162/ssrs-report-not-being-deployed-onto-the-report-server

Make sure you have access configured to the URL tp://localhost/reports using the SQL Reporting Services Configuration. To do this: 1. Open Reporting Services Configuration Manager -> then connect to the report server instance -> then click on Report Manager URL. 2. In the Report Manager URL page, click the Advanced button -> then in the Multiple Identities for Report Manager, click Add. 3. In the Add a Report Manager HTTP URL popup box, select Host Header and type in: localhost 4. Click OK to save your changes.
Now start/ run Internet Explorer using Run as Administator...
* NOTE: If you don't see the 'Site Settings' link in the top left corner while at tp://localhost/reports it is probably because you aren't running IE as an Administator or you haven't assigned your computers 'domain\username' to the reporting services roles, see how to do this in the next few steps.
Then go to: localhost/reports (you may have to login with your Computer's username and password)
You should now be directed to the Home page of SQL Server Reporting Services here: tp://localhost/Reports/Pages/Folder.aspx
From the Home page, click the Properties tab, then click New Role Assignment
In the Group or user name textbox, add the 'domain\username' which was in the error message (in my case, I added: DOUGDELL3-PC\DOUGDELL3 for the 'domain\username', in your case you can find the domain\username for your computer in the rsAccessDenied error message).
Now check all the checkboxes; Browser, Content Manager, My Reports, Publisher, Report Builder, and then click OK.
You're domain\username should now be assigned to the Roles that will give you access to deploy your reports to the Report Server. If you're using Visual Studio or SQL Server Business Intelligence Development Studio to deploy your reports to your local reports server, you should now be able to.

but am getting the following error when i try to deploy the report in bids
User generated image
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Hi PatelAlpesh, I am not clear as to what you mean by

Please make sure the user have permission to create report and report server.

If your service running wiht NT/user  then give permissions to that user as well.


where can i verify that  these settings are configured?
thanks