Link to home
Create AccountLog in
Avatar of Bes4dmin
Bes4dminFlag for Sweden

asked on

changing mail routing in domino 8.5

Hi I'm changing the smart hosts for outgoing internal and external mail but the changes doesn't seem to take effect.
Is there some .ini file that I can manually change or something?
Avatar of larsberntrop
larsberntrop
Flag of Netherlands image

tell router update config
Avatar of Bes4dmin

ASKER

I type in restart task router
Avatar of Sjef Bosman
> the changes doesn't seem to take effect
Unless you want this question to be a guessing game, can you describe what you configured, what you hoped for and what actually happens?
ok sorry, In domino admin on the Configuartions tab and Domains, I have a Foreign SMTP Domain.
Domain is "site.com" Destination Server is 172.16.8.2 (both domain and destination are not the real adresses)

Now all users have a forwarding address of site.com but when I send a mail to a user using user@site.com the domino console shows that it tries to sen to user@xxx.site.com

This xxx.site.com is an old forwarding address so the config doesn't seem to update properly
SOLUTION
Avatar of larsberntrop
larsberntrop
Flag of Netherlands image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Did you fill in the Configuration document, the field Relay host for messages leaving the local internet domain with a value like auth.smtp.1and1.fr?
@Lars yes
@sief I typed the IP of the host
Ok, what happens then when you send a new mail to the outside world? Can you follow the path it takes? Add a trace?
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Need to create a Formula agent:
Select db, View:Agents.
Click 'New Agent', type a name and choose Formula Agent
type:
Select Form="Person";
@SetField("MailAddress"; @Implode(@Trim(FirstName:Lastname); ".")+"@domain.com")

Save agent.
Goto to personsview,
select a person try on, an Choose a person, and do Actions:agent name
hey  didn't I suggest a tell router update config

Great that it is working for you!
Granting you the points cause I did remove the forwarding address field on the persona document.