Link to home
Start Free TrialLog in
Avatar of GoHuskers
GoHuskersFlag for United States of America

asked on

MAC OS 10.7 won't logon to iMAC

after I had to change the network password due to AD policy everythig went bad.
at this point when I logon it takes the username and password but after a few seconds it goes back to the username and passwoed screen and they are blank. It does NOT shake and revert back asking for a correct password as if it was wrong.
It seems to accept it but after a few seconds of a blank screen it reverts back and the username and password are blank.
I can logon on as a different user and I get fine.
 HELP!!
thanks
Avatar of E C
E C
Flag of United States of America image

Try this:
1. Boot up in single-user mode (hold Command-S during startup)
2. At the prompt, type:
       mount -uw / [enter]
       rm -r /Library/Preferences/DirectoryService [enter]
       exit
3. Once the Mac has finished booting, log in and configure Directory Access again.

(from here)

... or ...

1. Log into the Mac as the local Administrator
2. Open Terminal and type: lookupd -d [enter]
3. Then type: userWithName yourusername [enter]

... or ...

You can also try resetting the password:
- Boot the Mac from the OS X disc
- When the OS Installer menu appears, in the pull-down menu at the top select 'Change Password'

I read your post and it doesn't seem like your password is wrong, but maybe it just needs to be 'reset'  ?
Avatar of GoHuskers

ASKER

well I can get in now for some reason. I did not have to use your suggestions but thank you just the same.
Unfortunately  I am having other issues from here.
`when I try to open system "preferences" the icon bounces once and the little light below glows but the little light goes away and it never opens. There is no error pop up message.
`same thing when I try to open my VMware
`Safari states when I open it - "A keychain cannot be found to store "Safari"    "cncl"   "reset to default"   if you choose "Reset to defaults" it states "Are you sure you want to reset your keychain? This will delete all your saved passwords, keys, and certificates. You cannot undo this operation."
I did run "repair disk permissions" from the first aid tab but it did not help.
Am I having a keychain or permissions issue?
Try this:

1. Running the Keychain Repair

2. Log in as the original user (before you joined the domain) and see if your keychain works as that local user. If so, export the keychain, save it to a thumb drive (or email it to yourself), then log in as the domain user, retrieve that export file, and import it into your keychain for this new user.
I am also seeing some library permission issues such as access denied

Nov 12 09:22:51 OSC-MKT-009 upgradedb[733]: [0x10a9163a0] |Upgradedb|Error| Can't upgrade SyncServices data schema in directory /Users/ssutton/Library/Application Support/SyncServices/Local from version -1 to version 99: can't re/create data directory /Users/ssutton/Library/Application Support/SyncServices/Local due to error Error Domain=NSCocoaErrorDomain Code=513 "You don’t have permission to save the file “Application Support” in the folder “Library”." UserInfo=0x7ffddd1090a0 {NSFilePath=/Users/ssutton/Library/Application Support, NSUnderlyingError=0x7ffddd108f50 "The operation couldn’t be completed. Permission denied"}
make that domain user an Administrator on the mac, then reboot, then repair permissions.
`the user is an local administrator on the computer and was when I ran the repair disk permissions already
`i cannot get to users due to "system prefferences" not working

`when you say "run keychain repair" do you mean rest to default?
No. Not the same.
Open Keychain Access.
Under the main pull-down menu, select 'Keychain First Aid'
ASKER CERTIFIED SOLUTION
Avatar of E C
E C
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
`ran keychain repair and it did not find any issues
`this is an existing user so I want to be able to save her VMware image and other items etc.

do you think if I logon as local administrator and reset her password from there it would fix some of this?
try logging in using    domain\username   (in the user name field)
and the new password

does that let you in?
domain\username did not work
are you sure you are entering the password correctly? have you tried resetting it? Is the user locked out in Active Directory?
Appreciate all the advice
There must have been some corruption somewhere nothing seemed to make it come around.
Even though it was an existing user. I ended up saving VMware fusion image and desktop items and deleting user and just started over
Thanks again