Link to home
Start Free TrialLog in
Avatar of TokoZAR
TokoZAR

asked on

Outlook Scheduling assistant for external users

Hi all

I have an issue with Outlook scheduling assistant for external users.

It works fine when connected to our lan or APN but as soon as we try and use it from an external network like personal 3G or offsite ADSL  it simply does not work.

After reading this article I changed the the needed to our DNS.

This enabled auto discovery to work but still no remote scheduler.

This is the error:
your server location could not be determined

I have checked EWS and autodiscover virtual directories and both have pass through authentication enabled.

This is from a different article but I am a bit hesitant to try it
1.  Disable loopback on your Exchange server.  

Click Start, click Run, type regedit, and then click OK
In Registry Editor, locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
Right-click Lsa, point to New, and then click DWORD Value. (In Win 2008, its DWORD 32bit)
Type DisableLoopbackCheck, and then press ENTER.
Right-click DisableLoopbackCheck, and then click Modify.
In the Value data box, type 1 and then click OK.
Quit Registry Editor.
You may need to restart your server.
2. Follow http://support.microsoft.com/kb/940726 as required
3. Make sure MSExchangeAutodiscoverAppPool is set for pass-thru authentication and that it's in a running state
4. Make sure EWS and Autodiscovery virtual web folder is set to basic and integrated authentication only.  Do not enable anonymous.
5. Open up Exchange PowerShell and run test-outlookwebservices | fl command.  Make sure you are error free on anything relating to AS or Autodiscover.  If there are errors, drill in
6.  Troubleshooting using Test Email Autoconfiguration using Outlook to identify any errors.
That should be it.

Any advice would be appreciated.
Avatar of Simon Butler (Sembee)
Simon Butler (Sembee)
Flag of United Kingdom of Great Britain and Northern Ireland image

There shouldn't have been any need to make changes to the Exchange server configuration, therefore the steps you have posted I wouldn't bother with.

Primary reasons for availabilty service not working is lack of autodiscover. That means both the DNS entries AND the SSL certificate.
You have mentioned doing something with autodiscover and DNS, what exactly did you do?
If you configured the A record autodiscover.example.com, does that host name also appear in your SSL certificate?
If you made the change to an SRV record, was that in your PUBLIC DNS, not internal?

Create a test account and run it through the Microsoft test site at http://exrca.com/ and see what that flags up.

Including version information would be helpful as well.

Simon.
Avatar of TokoZAR
TokoZAR

ASKER

Hi

We added the following to our DNS
Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: mobile.xxx.co.za

I could then successfully run outlook's  Test Email Autoconfig.

Exchange 2010, Outlook 2010. Works 100% through OWA.



Here are the results from the test:
     
ExRCA is attempting to test Autodiscover for adriand@xxx.co.za.
       Autodiscover was tested successfully.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service was tested successfully.
       
      Test Steps
       
      Attempting to test potential Autodiscover URL https://xxx.co.za/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to test potential Autodiscover URL https://autodiscover.xxx.co.za/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA successfully contacted the Autodiscover service using the DNS SRV redirect method.
       
      Test Steps

Would the ones that fail be related to a missing A record?

Reason I ask is that https://mobile.xxx.co.za/owa/ works fine.
ASKER CERTIFIED SOLUTION
Avatar of Simon Butler (Sembee)
Simon Butler (Sembee)
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial