Link to home
Start Free TrialLog in
Avatar of WJPR_IT
WJPR_ITFlag for United States of America

asked on

Domain controller not recognizing domain after restore from backup

Yesterday I had to restore our file server [also a domain controller] to it's backup as of 1AM that morning. It is running Server 2008 R2 and is a Hyper-V VM, running on a 2008 R2 host. I am using Microsoft DPM 2010 for backup, the server is being backed up at the host level as a VM.

Once the restore from DPM [Restore to original instance] completed the server came up OK, it just did not seem to find the rest of the domain. I cannot log into it with any credentials except for the built in Administrator account. When I try to RDP to the server I get an error that the Local Security Authority cannot be contacted.

When I try running the command repadmin /syncall it fails with an error about 'The target principal name is incorrect'

There are errors in the event log about the Knowledge Consistency Checker detecting that it is failing to replicate with the directory service. This may be related to:
http://support.microsoft.com/kb/214745 

Running dcdiag produces multiple errors, primarily with Key Distribution Center issues regarding authentication.

Any help in figuring out what is wrong would be greatly appreciated.
Avatar of WJPR_IT
WJPR_IT
Flag of United States of America image

ASKER

Also possibly related:

The Network & Sharing Center shows that the server is connected to a Private Network, not to the domain.
Avatar of Miguel Angel Perez Muñoz
Try making non-authoritative restoration from backup: http://technet.microsoft.com/es-es/library/cc784922(WS.10).aspx
Avatar of WJPR_IT

ASKER

Drashiel

Is that possible when the original backup was done with DPM instead of ntbackup?
ASKER CERTIFIED SOLUTION
Avatar of WJPR_IT
WJPR_IT
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of WJPR_IT

ASKER

This fixed the problem.