Link to home
Start Free TrialLog in
Avatar of morten444
morten444

asked on

Cant get VMware ESXi 4.0 to see my ISCSI on new Synology DS712+

I have an IBM xSeries 346 where I run VMware ESXi 4.0
I am in lack of storage so bought a Network Storage unit Synology DS712+ that isV VMWare ready.

On My Synology DS712+ I created a Volume on on this i Created a ICSCI Lun and Target
To test that it works I started ISCSI Initiator on my Windows 7 and when i add the IP of my Synology DS712+ its seen and connected to the IQN Name straight away

Based on this i conclude that my Network Storage is correctly setup.

Now I connect to my WMware 4.0 using VSphere Client 4.00

On the Configuration TAB--> Network
I only have 1  Segment. I read everywhere that its best with 2 but now for testing I use one as I have another setup running with 1 (so trying to compare as this is quite new for me)

On the Configuration TAB -->Storage Adapter I now see "ISCSI Software adapter"
(See attached Picture)
I have enabled it and written in the IP of my Network Storage. I have tried both Dynamic and Static Discovery.
I then do a rescan but the ISCSI does not show up when trying on ESXi but does show up when trying on my Windows7

I am stuck. I am new to this
I have not done anything in Command Prompt as the guide i tried to follow was this one:
http://techhead.co/vmware-esxi-4-0-vsphere-connecting-to-an-iscsi-storage-target/

(tried with 1 and 2 network segments)

My Windows 7 is on the same segment as my ESXi and Network Storage
I can ping them both so they can also see each other

Anyone with a suggestion on how to trouble shoot this?

Thanks in advance
ISCSI.jpg
Avatar of compdigit44
compdigit44

I mention that you connected your Windows workstation to this volume did you format the volume under Windows by any chance?

From the command-line are you able to rescan are you able to see the volume?

Let me know how you make out..

Check out this article as well
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1008083
Avatar of morten444

ASKER

Hi
Thanks for your reply
I did actually not complete the setup when testing with windows
I just used the ISCSI Initiator to see that I actually could see the ISCSI and it said "Connected"
I then disconnected straight away and continued my PD on the ESXi

Regarding the command prompt
I have to ask very basic here. I read somewhere that ESXi 4.0 does not have a command prompt. I really cant find how to enter that mode.

I did try from the ESXi itself (the yellow background) to ping My Network Storage using "Test Management Network"

I was not able to run ping test " vmkping 10.1.10.100" as I have not found a way to enter command promt on it
In the film on the link you sent at 0:49 it says "login to ESX Host"
I cant see how he does it.
Is there a way and should I still do that despite beeing able to ping my Network Storage with the ISCSI?

Best Regards
Instead of retyping how to access the console in ESXi check out the following article ;-)...

http://www.yellow-bricks.com/2008/08/10/howto-esxi-and-ssh/

Then try all steps listed in the VM document I post earlier..

Let me know how you make out..
Hi. Thanks again
I did get it into a promt now, finally :)

I managed to do a Ping and a vmkping. Both OK

Then i found this:
http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=8858900

To reconnect an iSCSI array to an ESX host:
Point 1 to edit this file i was not able. I wrote vi /etc/vmkiscsi.conf
and just got a page full of
~
~
~
Dont know the editor well enought i thing

Point 2 to Disable and re-enable the Software iSCSI initiator went ok
I then go to to a scan using command:
esxcfg-swiscsi -s

All it returns is:
Scanning vmhba33...
~#

Nothing more

I also did a # nc -z 192.168.0.9 3260

All it returns is:
-ash : nc: not found

For me it just looks right everything accept the last but i can ping so guess not relevant

hm, not sure where to go from here
ASKER CERTIFIED SOLUTION
Avatar of compdigit44
compdigit44

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Hi
You are a star!!!
This link:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1038065

I followed it step by step
Then i went through the whole process again from setting up the Network Station and Configure it on ESXi as well
Next time i did a Scan it found it
I have now set it up, added it to storage and all seems good

Thanks for not giving up on me :)

Regards
Morten
Despite complex, he did not give up and kept coming up with ideas until resolved.
Thanks alot