Link to home
Start Free TrialLog in
Avatar of RKoons
RKoonsFlag for United States of America

asked on

Win 7 printing with a Kyocera

I have this ongoing problem with loading print drivers and Windows 7, 64 bit. There are some issues with HP printers as well, but specifically with Kyocera 620 MFP.

I have successfully installed the 64 but print drivers onto my 32 bit print server, so I don't think the problem is there.

As a typical user, I can go to the server, select the printer, and it successfully begins installing the drivers. It get's about 90% finished, and then gives the user an access denied message.

Our support company said that rather than go through the wizard, to go into my network places, view the shares and printers on the print server and connect to it this way -but this gives me the same error.

Kyocera said that they have not heard of this problem before, but suggested to install the latest print driver. Although I am not apposed to this, it seems like a permission thing on the workstation end.

Earler posts here suggested to disable UAC, which I did, and to set the "Point and Print" local group policy enabled, with settings to not show warnings...", which I also did.

Finally, I figured if I go into the workstation and change the permissions on the "Spooler" folder of the workstation to allow "Authenticated Users" full control over these folders and files, that this might solve the problem. I never got to try this because there were so many files and folders that would not take the permission change that I aborted the idea, and ended up here.

The only thing I have seen that works is to either make the users a local admin, or install the drivers as the admin first, and then the drivers seem to load OK MOST OF THE TIME... This however is not a workable idea because of the time it would take to set it all up.

as you can see, I have put alot into this already, and I'm out of ideas.

Thanks in advance for youir support.
Avatar of cantoris
cantoris
Flag of United Kingdom of Great Britain and Northern Ireland image

Use Process Monitor from sysinternals.com.

Log in as the affected user, shift-right-click on your downloaded copy of procmon.exe and run it as an administrative user.  Of the four things in a row selected on its toolbar, deselect the two on the right.
Now trigger your driver install fail and then stop procmon's monitoring by clicking the magnifying glass.  On the results column, right-click and individually Exclude all entry types except Access Denied.  When you find an Access Denied you can right-click and Include it to get rid of all the other entries in one go.

That will show you where the permissions need tweaking.  Post the results here if you want as there are always some false positives - eg references to a joystick!
Avatar of RKoons

ASKER

Thanks...

I will play with this tomorrow and let you know how it works!
Avatar of RKoons

ASKER

Results from my first try was not so good.

First time, the only "Access Denied" I got was from the Process Monitor program.

I then noticed that the error I got was a bit different. This time, I compleatly removed all instances of the printer, including deleating the drivers and running the Kyocera driver cleaner. This was to reproduce a condition similar to a user who had never installed the printer before.

The error is attached:

I will keep trying.
Kyocera.JPG
I think error code 2 is a "file not found" error!

If you've got the patience you could try looking through procmon.exe to see if you can spot why.  You'll often get a series of file not found errors as the PC searches various paths until it finds a file so you can't just exclude all Successes!  Do though look for a series of Not Found errors where the filename is then not found.

My own use of connecting machines to shared printers has always involved having the driver installed by admin first though...
Avatar of RKoons

ASKER

First of all... Just simply thanks!!!

Although I don't always get a solution, this is the only place I can go where I get a focused discussion of the problem rather than the rambeling you get from most suppoft forums.

Anyway, an update:

I have been researching this issue, and I found that it is a common issue that alot of people have. Most people opt for a workaround rather than a solution, like install a local printer rather than working from the server hosting the printer.

However, I did find an article that said that starting and stoping the spooler service fixes the problem, although temporarly.

The strange thing is: this seemed to work!

However, I DO NOT consider this to be a solution to the problem, just an interesting addition to the process.

I am going to run some more tests using the Process Monitor...

Thanks
Avatar of RKoons

ASKER

Update:

I have been working with Process Monitor, and although I like what it has to offer, I have had no luck getting any specific information from it.

I tried enabling UAC, up to the first step above off. interesting thing: as long as I provided the admin name and password, it would install the drivers no problem.

This tells me that setting the UAC to off removes me from getting the login prompts, but does not remove me from needing it. This is because all I get is the access denied error after the fact.

In XP, I was able to go into "Local Security Policy" settings, and add the local users group to the "Load and unload device drivers" setting.

I have done the same here, but it does not seem to make any difference.

The only other thing I did differently on my Win7 machines is:

I used to add the domain users group to the local "Power Users" group, allowing the average user to have elevated permissions without going all the way to local admin.

When I started using Win7, I noticed that the default group used for local permissions was "Authenticated Users", so I added the Domain users group to this.

I don't know if any of this helps, but I thought I would add the information as I grunt through this.

At this point, the only options I have found are:

Install the printer first as the admin, then as the user.

Install a local printer rather than shared from the server.

Make the domain users members of the local admins group.

Upgrade my print server to at least server 08.
ASKER CERTIFIED SOLUTION
Avatar of RKoons
RKoons
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of RKoons

ASKER

My reasons are in my post...