Link to home
Start Free TrialLog in
Avatar of chrislindsay
chrislindsayFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Adding a line of addition fixed text to the body of an immediate alert email in SharePoint 2010

Hi Experts,
I am trying to add a simple text line to the body text of an immidiate alert email of a Document Library I have created on a Sharepoint website.
I understand that you shoud make a copy of the alerttemplates.xml, rename the xml file and use stsadm -o updatealerttemplates -url -filename  , IISRESET and restarted the SharePoint Timer Service.
What I don't know, is, how do I inset a simple line of text in the body of the email?
Do I need to reference in the database or update a tag within the alerttemplates.xml
Any help would be great thanks
Avatar of Rainer Jeschor
Rainer Jeschor
Flag of Germany image

Hi,
you will have to update the Xml file - the element is depending on the position of the line of text.
If you want to add it to the end of the mail body, then you might have to adjust the "Footer" element of your alert.

HTH
Rainer
Avatar of chrislindsay

ASKER

Thanks for the help, could you please give me an example of what I should be adding?
Should it be:-
 <RowFooter>
        <HTML><"This is a test"></HTML>
    </RowFooter>

?

Thanks
Hi,

if you want to have the output only once in the email you should add it to the footer.

From the standard template XML replace
    <Footer><HTML><![CDATA[
  </table>
 </body>
</html>]]></HTML>
    </Footer>

Open in new window

with
    <Footer><HTML><![CDATA[
  </table>
<p>And here comes your single line of text</p>
 </body>
</html>]]></HTML>
    </Footer>

Open in new window


HTH
Rainer
Hi Rainer,

Thanks for the update.

I have replaced the file with the text advised in your last post and rebooted the server.  I have created an alert.  The email doesn't contain the text.  Any idea.  Am I missing something?
ASKER CERTIFIED SOLUTION
Avatar of Rainer Jeschor
Rainer Jeschor
Flag of Germany image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Hi Rainer,
I changed all the nodes to be sure...
I have attached the file
Thanks for your help.
alerttemplates.xml
Worked well once I picked the correct mode Thanks!