Link to home
Create AccountLog in
Avatar of glenn_r
glenn_r

asked on

IIS7 asp.net "HTTP Error 500.22 - Internal Server Error (An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.)

server 2008 r2 64
iis7

I have a couple of servers where the app is running. I've set up everything like the other servers but I get the error listed in the title. Pipeline is to be set to integrated. I'm able to run the app in classic mode but some functionality does not work. Why won't it run for an integrated pipeline on this machine? Any ideas?
SOLUTION
Avatar of Rainer Jeschor
Rainer Jeschor
Flag of Germany image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of glenn_r
glenn_r

ASKER

The entire project folder including the app.config was identical on either server. I've attached the machine.config from each server. Not sure how to compare. Please review and let me know.
machine-from-customer.zip
machine.zip
I don't need the machine.config. I just want to know if the application pool under that the web site / web applicationis running is configured correctly.
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of glenn_r

ASKER

I've requested that this question be closed as follows:

Accepted answer: 0 points for glenn_r's comment #a38614195

for the following reason:

I found the answare
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of glenn_r

ASKER

With help from the community I was able to zero in on the problem. Thanks