Link to home
Create AccountLog in
Avatar of lustrja
lustrja

asked on

2Wire 3600 AT&T Uverse DSL modem not forwarding ports with static IP

Ok, 4.5 hours later and 3 different techs from AT&T Uverse Support, these guys cannot get it right.

I have a block of 8 static IP addresses and YES I know that this model modem cannot be truly bridged so I thought I would take my router out of the mix to see if this is an issue with AT&T.

So, I plug my laptop into 1 of their ports of their modem, my firewalls turned off for both public and private IP networks and I'm running Win 7 Ultimate with no AV with all of MS's updates.  I only use this laptop to configure my routers, etc... and I've been doing this for years so someone please entertain me.

The AT&T tech setup their DSL modem so that it could hand out my Public IP's to any of the ports that I plug into.  My laptop once connected gets to the internet with no issues with the assigned public IP address and YES they did turn off the firewall for the device being plugged in.

Once we try to open ports - say (port 3050) and we assign it to my laptop and go to like an open port check tool website which I've used millions of times and I know is accurate (http://www.yougetsignal.com/tools/open-ports/), it keeps showing that the port is closed no matter what we do.  

They've tried the DMZ Plus mode, still no worky, I've tried this "There is no true bridge mode on the 2Wire routers.  However, you can still configure it such that almost all functions of your own router will work properly.
 
1. Set your router's WAN interface to get an IP address via DHCP.  This is required at first so that the 2Wire recognizes your router.
2. Plug your router's WAN interface to one of the 2Wire's LAN interfaces.
3. Restart your router, let it get an IP address via DHCP.
4. Log into the 2Wire router's interface.  Go to Settings -> Firewall -> Applications, Pinholes, and DMZ
5. Select your router under section (1).
6. Click the DMZPlus button under section (2).
7. Click the Save button.
8. Restart your router, when it gets an address via DHCP again, it will be the public outside IP address.  At this point, you can leave your router in DHCP mode (make sure the firewall on your router allows the DHCP renewal packets, which will occur every 10 minutes), or you can change your router's IP address assignment on the WAN interface to static, and use the same settings it received via DHCP.
9. On the 2Wire router, go to Settings -> Firewall -> Advanced Configuration
10. Uncheck the following: Stealth Mode, Block Ping, Strict UDP Session Control.
11. Check everything under Outbound Protocol Control except NetBIOS.
12. Uncheck NetBIOS under Inbound Protocol Control.
13. Uncheck all the Attack Detection checkboxes (7 of them).
14. Click Save.
 
Your router should now be able to route as if the 2Wire was a straight bridge, for the most part.
 
Inbound port 22 might be blocked, and inbound ports 8000-8015 might also be blocked, and there's nothing that can be done about it.
 
This is how I have my 2Wire configured, and I have a Cisco 2811 behind it doing IPSec, IPv6 tunnels, etc."  which most says it works but still no worky for me.

What's really wierd is if I plug my router in and set the static IP to it's WAN interface and plug my laptop into the router and externally ping the IP address from another PC and I turn on WAN ping enable, I can ping and get replies to the IP address.  When I turn off WAN ping enable, it stops pinging and times out like it's supposed to.

Why isn't port forwarding working even directly plugged into their DSL modem?  Is this a back-end provisioning issue and does anyone know what to tell these lame AT&T Uverse support folks to look for?  Do I have a potentially bad modem?  They've reset this thing like 5 times and I just got this modem and service turned up the other day.

I know that in the past, I've had to contact them to open port 25 for some folks that use an Exchange Server because it's closed.  They usually open it up and bam it works.  We've tried port 80, port 3050 and no matter what we try to open from the modem, it still shows closed.  Someone please help me.  Thanks in advance!
ASKER CERTIFIED SOLUTION
Avatar of ckluka
ckluka

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of lustrja
lustrja

ASKER

Thanks for responding.  I've even tried assigning static a static ip to my DLINK router and it still will not do port forwarding.

This same router works fine on cable modem networks without a hitch.

Any other ideas out there?
Avatar of lustrja

ASKER

Excellent feedback