Link to home
Start Free TrialLog in
Avatar of k_hoffhines
k_hoffhinesFlag for United States of America

asked on

Can access a NAS from hostname but not ip

We are trying to setup a server with a Buffalo NAS storage device, we have the device connected to our network at a "Storage1" and the IP of 10.10.X.X we have connected their support and haven't had ANY luck with them.

This is how far we have got  we can connect to shared folder via \\computername\folder name but not \\ip\folder name

When connecting to the ip address it says access denied on restricted folders, but via the computer name its perfectly fine any thought suggestions ideas??


Actual Product
http://www.buffalotech.com/products/network-storage/professional-and-business-class-nas/terastation-pro-rackmount-1

Server 2008 R2 Std DC
- all updates done
- on the most current version of firmware

thanks for all your help!!
Avatar of sfossupport
sfossupport
Flag of United States of America image

I would check your forward and reverse lookup on your dns. Or you can create an entry in your hosts file for this one hostname and try again.
Avatar of k_hoffhines

ASKER

The issue we are having is when we go \\ipaddress it provides us with the shares, but when we double click on one it prompts again for our username and password so we try domain\username and then it says access is denied..
How is this NAS configured ? And what file system is the NAS using ? Is it using ext3 or NTFS ?
It may not be asking for a windows passowrd but a password setup on the NAS.
@sfossupport

- Raid 5 with 3 Drives and a hot spare
- XFS File System
What permissions did you set on the xfs shares ? Did you set a generic user on each share ?
What are the permissions on the share that you are having the issues with
User generated imageUser generated imagewhen logging in as the "test" domain user it will only work to get to the directory via the shared name as explained above :)
ASKER CERTIFIED SOLUTION
Avatar of sfossupport
sfossupport
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
User generated imageUser generated imageAttached are 2 photos after adding reverse dns entries as well and still no luck, any suggestions, as seen in the photos via the host name it works fine but via the ip address it asks to logon when I am already logged onto the network with my username that works with the \\hostname

thanks
First of all, it wouldn't be a DNS issue, as you are accessing the device via IP address.  It seems to be a Linux permissions issue within the NAS, as you are accessing the device via IP address from windows, and seeing the folders, but can't open the shared folder.  Have you set up groups and users on the NAS or did you have the NAS download these from Active Directory?

I'm not sure which Buffalo NAS you have, but this may be of assistance:

http://eis.comp.lancs.ac.uk/~carl/blog/2010/06/not-happy-with-the-buffalo-terastation-iii-nas/
@profgeek we have the users fully downloaded from the active directory.
Have you tried adding a group manually and then seeing if those permissions work?  Note that I don't have a Buffalo NAS (I use Synology), so I'm just helping from a general perspective here.  Also, have you tried setting up a share for ftp to see if that works?  I'm just wondering if the loaded AD permissions are working on the samba side but not on the IP side.
Avatar of Aaron Tomosky
Found this:
http://forums.seagate.com/t5/BlackArmor-NAS-Network-Storage/NAS-220-accessible-by-hostname-not-by-IP-address-Windows-2008-R2/td-p/165448

I'm thinking this relates to something in the activedirectory binding. So the device is allowed to check active directory credentials if you hit it by hostname, but by IP your AD server doesn't respond right. That would explain everything.

Check the AD logs when you try to connect by hostname and IP and see if you notice anything along those lines