Link to home
Create AccountLog in
Avatar of Juneaucounty
JuneaucountyFlag for United States of America

asked on

Out of Office Assistant error server is currently unavailable

All computers in my network get an error in outlook when trying to setup the out of office assistant. The error is "Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try Again later".

I recently renewed our self signed certificate in April 2012. I have been doing some research and it sounds like my issue has something to do with the autodiscover. All users can change the out of office assistant in OWA with no problems. When I renewed my certificate, I did not setup anything with Autodiscover. FYI I am running Exchange 2007.

How do I fix my issue of all outlooks out of office assistant not working? Is it something to do with Autodiscover not being setup?

If it is Autodiscover not being setup, How do I set it up? I have tried to research and it doesnt make sense to me.

FYI info on my AutoDiscover

My AutodiscoverServiceInternalUri is https://exchange.domain.local/Autodiscover/Autodiscover.xml


I also tried testing the Autodiscover by using exchange shell command:

Test-OutlookWebServices -Identity anelson@co.juneau.wi.us | fl

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address anelson@co.juneau.
          wi.us.

Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://exchange.domain.local/Autodiscover/Autodiscover.xml.

Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://exchange.domain.local/EWS/Exchange.asmx. The elapsed time was 350 milliseco
          nds.

Id      : 1015
Type    : Information
Message : [EXCH]-The OAB is not configured for this user.

Id      : 1014
Type    : Information
Message : [EXCH]-The UM is not configured for this user.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.

Thank you!
Avatar of dan_blagut
dan_blagut
Flag of France image

Hello

Yes the Autodiscovery is needed for OoO, free/busy infos and Ofline adressbook.
And http://blogs.technet.com/b/exchange/archive/2007/04/30/3402138.aspx say:
 Outlook is hard-coded to find the Autodiscover end-point by looking up either https://company.com/Autodiscover/Autodiscover.xml or https://Autodiscover.company.com/Autodiscover/Autodiscover.xml (where company.com is the portion of the user's SMTP e-mail address following the @ sign). This means that to service clients in this scenario we must provide connectivity to one of these URLs.

Dan
Avatar of Juneaucounty

ASKER

Hey Dan:

thanks for the response. I read a  little of that article and it says:

For non-domain-joined clients or clients that are not able to directly access the domain, Outlook is hard-coded to find the Autodiscover end-point by looking up either https://company.com/Autodiscover/Autodiscover.xml or https://Autodiscover.company.com/Autodiscover/Autodiscover.xml (where company.com is the portion of the user's SMTP e-mail address following the @ sign). This means that to service clients in this scenario we must provide connectivity to one of these URLs.


All my users are joined to the domain so is this still something that is needed?

If so how do i get my certificate and autodiscover working?

Thanks
you juste need to be sure that the dns is OK meaning the https://company.com/Autodiscover/Autodiscover.xml and  https://Autodiscover.company.com/Autodiscover/Autodiscover.xml point to the IP of Exchange server where Autodiscovery is.
Hey Dan:

Reading another article on this and it told me to run power shell command:

Get-autodiscovervirtualdirectory | fl Name,internalurl,externalurl


I get back the following:

Name : Autodiscover (Default Web Site)
 InternalUrl :
 ExternalUrl :


I am assuming i need to put something in the internalurl section. I am not sure what i need to put there. Its telling me i can use one of the following addresses:

Depending of the url of your choice the appropriate record must be created in DNS for either
 https://primarysmtpdomain/autodiscover/autodiscover.xml or https://autodiscover.primarysmtpdomain/autodiscover/autodiscover.xml.


Which one should i use and i am not sure what i need to put for the primarysmtpdomain section of the url?

Then it says something about adding an Autodiscover (A record) in my DNS. Is the article talking about my internal DNS server on my network or my outside DNS for web?
Awesome. How do I know where https://company.com/Autodiscover/Autodiscover.xml and  https://Autodiscover.company.com/Autodiscover/Autodiscover.xml are pointing to?

How do I point them to the right location?

Do i point them to my internal private IP address? We are using 172.20.X.X ip scheme inside
ASKER CERTIFIED SOLUTION
Avatar of dan_blagut
dan_blagut
Flag of France image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Ok to recap everything, All i need to do to get my out of office assistant to work in outlook/exchange is the following:

1. Run exchange powershell command

New-AutodiscoverVirtualDirectory -Websitename <websitename> -BasicAuthentication:$true -WindowsAuthentication:$true


Question: What goes in the websitename section of this command? My OWA website? https://juneauexc.co.juneau.wi.us/owa?

2. Change my DNS (hosted by Godaddy)

Create an (A) Record called Autodiscover that points to my Public IP address for my mail.co.juneau.wi.us (exchange mail)

Create a SRV service = _autodiscover     Protocol = _tcp      Port = 443   Target = mail.co.juneau.wi.us

Is that it? Do need to change my certificate? All I did to create my certificate is the following:

Get-ExchangeCertificate -thumbprint “ASDFLSADFJ730” | New-ExchangeCertificate

Enable-ExchangeCertificate -thumbprint “ALDKFJALSD27BE” -services IIS

So i get a new certificate and enable IIS service on it. I did not do anything with autodiscover on the certificate side.
Can anyone help me with this issue?